W3C home > Mailing lists > Public > public-web-perf@w3.org > October 2010

Re: [Web Timing] Interface names

From: Zhiheng Wang <zhihengw@google.com>
Date: Thu, 21 Oct 2010 11:52:32 -0700
Message-ID: <AANLkTikMx6FEsU2QzCgKwJTBE92eKNwBucBOBmTPGQda@mail.gmail.com>
To: Tony Gentilcore <tonyg@chromium.org>
Cc: Anderson Quach <aquach@microsoft.com>, "public-web-perf@w3.org" <public-web-perf@w3.org>
On Thu, Oct 21, 2010 at 11:26 AM, Tony Gentilcore <tonyg@chromium.org>wrote:

> Sorry I was unable to join the call yesterday. Did this get resolved?
> Should be a detail that is easy to close the loop on.
>
> On Mon, Oct 18, 2010 at 12:07 PM, Anderson Quach <aquach@microsoft.com>wrote:
>
>> Thanks for catching this. I agree we should be consistent with the
>> interface names, especially moving towards an implementation where the we
>> can drop the vendor prefix.
>>
>>
>>
>> The open question is that do we want to move NavigationInfo Ó Navigation
>> or keep NavigationInfo.
>>
>>
>>
>> Proposed interface names:
>>
>> Performance
>>
>> NavigationInfo ľor- Navigation
>>
>> NavigationTiming
>>
>
> I like the idea of using Performance to scope the sub interfaces like you
> did in the IE implementation.
>
> What about Performance (window.performance), PerformanceNavigation
> (window.performance.navigation) and PerformanceTiming
> (window.performance.timing)?
>

   sounds good to me.

   Since we are on this, we should settle that for ResourceTiming and
UserTiming as well. How about:
   ResourceTiming: window.performance.createResourceTimingCollector()
UserTiming: window.performance.timing.mark() - or - <something else>?


cheers,
Zhiheng


>
>
>>
>>
>> As for the name of the interface prototype object, on IE we believe that
>> the WebIDL spec [1] is crucial to get right. The naming conventions of the
>> interface prototype object should be left up to that working group.
>>
>>
>>
>> [1] http://www.w3.org/TR/WebIDL/
>>
>>
>>
>>
>>
>> *From:* public-web-perf-request@w3.org [mailto:
>> public-web-perf-request@w3.org] *On Behalf Of *Tony Gentilcore
>> *Sent:* Thursday, October 14, 2010 8:35 PM
>> *To:* public-web-perf@w3.org
>> *Subject:* [Web Timing] Interface names
>>
>>
>>
>> Since user agents expose the interface names to the DOM, I'd like to
>> reconsider the interface names as a whole to get a consistent scheme.
>>
>> Spec              IE                                WebKit
>> Performance       MSPerformancePrototype            Performance
>> NavigationInfo    MSPerformanceNavigationPrototype  Navigation
>> NavigationTiming  MSPerformanceTimingPrototype      Timing
>>
>> I recommend we standardize on Performance, PerformanceNavigation, and
>> PerformanceTiming.
>>
>>
>>
>> For every other interface I checked, IE uses a Prototype suffix, but other
>> UAs don't use it and it isn't in any specs that I've found. So I assume that
>> we should standardize on something without Prototype and IE will might add a
>> Prototype suffix for internal consistency.
>>
>>
>>
>> Thoughts?
>>
>> -Tony
>>
>
>
Received on Thursday, 21 October 2010 18:53:02 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 21 December 2010 18:13:55 GMT