W3C home > Mailing lists > Public > public-web-notification@w3.org > March 2012

Re: Rename cancel() (was Feedback from Safari on Web Notifications)

From: Jon Lee <jonlee@apple.com>
Date: Tue, 13 Mar 2012 15:34:05 -0700
Message-id: <CAAB61B2-784C-4F7B-BE49-F699E7B8D656@apple.com>
To: public-web-notification@w3.org
Bump? Any thoughts on this?

Jon

On Mar 12, 2012, at 1:24 AM, Jon Lee <jonlee@apple.com> wrote:

> Second point for continued discussion: rename cancel() to close(). I thought the asymmetry between cancel() the call and onclose() the event listener made the API confusing.
> 
> I think I still prefer close() and onclose() even if its name doesn't cover the queueing situation, but can go with using "remove" and "onremove". Least desirable to me is cancel()/oncancel().
> 
> Jon
> 
Received on Tuesday, 13 March 2012 22:33:17 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 17 December 2012 14:48:28 GMT