W3C home > Mailing lists > Public > public-web-notification@w3.org > March 2012

Rename replaceID attribute (was Feedback from Safari on Web Notifications)

From: Jon Lee <jonlee@apple.com>
Date: Mon, 12 Mar 2012 01:24:38 -0700
Message-id: <1A4A54DE-2294-4CD4-94F9-D72BEF0D90DA@apple.com>
To: public-web-notification@w3.org
Hello everyone,

The initial discussion based on Safari's feedback looked at one issue, but hasn't looked at the rest. To avoid confusion, I'm splitting out the other outstanding 3 points into separate threads.

To recap, the original proposal was to replace setReplaceId() with an attribute "id". John Gregg felt "id" suggested uniqueness, which is not true. I felt that "id" was the problem then, and suggested using "tag" to imply this common relationship between notifications. Thoughts?

Received on Monday, 12 March 2012 08:25:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 19:53:13 UTC