Re: [web-nfc] Consider removing .nfc namespace

The NFC interface looks good to me. It is also in line with Travis' 
comments.

I have a question regarding your examples.

In Case 2 for instance, we have one Promise returned. Now say one push
 (write) succeeded and one failed. We reject the promise. The 
developer may think the tags were not modified, but one of them was. 
Therefore unless we can unroll partial success as it were a 
transaction we cannot say the push failed. Nor can we say the push 
succeeded. One of them succeeded and the other one failed. We would 
need 2 Promise objects to convey that. If we would return a sequence 
of Promise objects, one per adapter, we would need to identify them. 
That is not trivial to do without fingerprintable information that are
 visible to the page (or if I am wrong here, suggest a solution). Even
 then I'd not go there. If we choose to not identify the adapters, 
that may also work, at least the developer knows what is the state, 
even though it cannot be mapped exactly to adapters. Anyway, it kind 
of sucks returning an array of Promises.

I see only 2 acceptable ways out: 1. undo the successful write 
(transaction model) and reject, 2. work with only one adapter. If we 
choose 1, we need to specify the transaction.

I would like to understand, is it more complex to work with one 
adapter than with multiple? Or we don't want to lose the parallel 
reading functionality?

-- 
GitHub Notif of comment by zolkis
See https://github.com/w3c/web-nfc/issues/67#issuecomment-151872992

Received on Wednesday, 28 October 2015 15:00:34 UTC