W3C home > Mailing lists > Public > public-wai-ert@w3.org > June 2009

Re: [Content-in-RDF] proposed changes

From: Shadi Abou-Zahra <shadi@w3.org>
Date: Wed, 17 Jun 2009 12:46:05 +0200
Message-ID: <4A38C96D.6090709@w3.org>
To: Johannes Koch <johannes.koch@fit.fraunhofer.de>
CC: ERT WG <public-wai-ert@w3.org>
Hi Johannes,

Johannes Koch wrote:
> Hi group,
> 
> I will change the following class names:
> Base64Content to ContentAsBase64,
> TextContent to ContentAsText,
> XMLContent to ContentAsXML.
> 
> I will change the following property names:
> xmlEncoding to declaredEncoding,

I'm OK with this, it reflects its XML name "EncodingDecl". Have you also 
considered just "encoding"?


> xmlLeadingMisc to leadingMisc,

How about prologMisc? (XML calls the entire front-matter the "prolog" 
and this part of it "Misc", which where the name may have derived from)


> xmlRest to rest,

The XML spec calls this "element". How about calling it "elements"?


> xmlStandalone to standalone,
> xmlVersion to version.

ACK. I like these, nice and simple.


> I don't have a name change proposal for the XMLDecl class and xmlDecl 
> property.

I strongly suggest that we don't use only caps for differentiating 
between the class and property names.

How about just "decl" for the property and "DeclarationOfXMLfile" for 
the class? See below for more:


> But: Maybe we can drop them and put declaredEncoding, 
> standalone and version to ContentAsXML. In the DOM there's no interface 
> for the XML declaration, but the corresponding properties belong to the 
> Document interface. What do you think?

This makes sense too. Even if DOM had an interface for these, it still 
belongs to the respective ContentAsXML blurb. This way we also bypass 
modeling XML into RDF.


Best,
   Shadi

-- 
Shadi Abou-Zahra - http://www.w3.org/People/shadi/ |
   WAI International Program Office Activity Lead   |
  W3C Evaluation & Repair Tools Working Group Chair |
Received on Wednesday, 17 June 2009 10:47:16 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 17 June 2009 10:47:16 GMT