W3C home > Mailing lists > Public > public-wai-ert@w3.org > September 2008

Re: Namespace class for Pointers in RDF

From: Michael A Squillace <masquill@us.ibm.com>
Date: Tue, 2 Sep 2008 13:52:37 -0500
To: "ERT WG " <public-wai-ert@w3.org>
Message-ID: <OF5590773E.2CB119B4-ON852574B8.0066EAFD-862574B8.0067AC0B@us.ibm.com>
+1 for renaming Namespace class as XMLNamespace
I am also fine with namespaceName for representing either a URI or IRI. As 
Carlos notes, this is certainly in accordance with the spec. However, we 
could also call the property , following XSD [1], 'anyURI' and explicitly 
note, as XSD does, that this may be either an IRI or URI. This might avoid 
confusion with the use of 'namespaceName,' which although compatible with 
the spec, might not be as familiar a term.

[1] - http://www.w3.org/TR/xmlschema11-2/#anyURI

--> Mike Squillace
IBM Human Ability and Accessibility Center
Accessibility Tools Framework (ACTF) co-technical lead
http://www.eclipse.org/actf

W:512.823.7423
M:512.970.0066

External: http://www.ibm.com/able
Internal: http://w3.ibm.com/able



Shadi Abou-Zahra <shadi@w3.org> 
Sent by: public-wai-ert-request@w3.org
09/01/2008 09:40 AM

To
Carlos Iglesias <carlos.iglesias@fundacionctic.org>
cc
public-wai-ert@w3.org
Subject
Re: Namespace class for Pointers in RDF







Hi Carlos,

This is an important point, thank you for raising it!

It seems that XPointer expressions use URI references, and that IRI 
references need to be escaped into URI references:
  - <http://www.w3.org/TR/2003/REC-xptr-framework-20030325/#escaping>

It may be best to adopt this approach as well. We could keep the term 
'namespaceURI' intentionally, to signal that the namespaces should be 
URI references. Additionally, we should adopt the definition and point 
readers to the XPointer specification for more background.

On the other hand, if we decide to use IRI references directly then we 
will need to consider the impact of it for the RDF/XML serialization of 
pointers and therefore also for EARL reports.

Regards,
   Shadi



Carlos Iglesias wrote:
> 
> Hi group,
> 
> Currently the Namespace class consists of:
> 
> Namespace (ptr:prefix, ptr:namespaceURI)
> 
> We created the Namespace class to be able to indicate namespaces for 
XPath and XPointer expressions, so our usage is limited to XML 
Namespacing, and thus I think we should name the class XMLNamespace to 
distinguish it from other namespacing mechanisms.
> 
> Additionally, XML 1.0 makes use of URIs for the namespace identification 
[1], but XML 1.1 use IRIs with the same purpose [2]. So, if we use a 
namespaceURI property we are somehow restricting the usage of the 
vocabulary with XML 1.1
> 
> The options are using a namespaceIRI property instead, as it is a 
superset of URIs (my only concern is that the term is far less "popular"), 
or a more generic name for the property (e.g. namespaceName as in the 
specification)
> 
> So the class could look like:
> 
> XMLNamespace (ptr:prefix, ptr:namespaceName)
> 
> Do you have any thoughts about this?
> 
> [1] - [http://www.w3.org/TR/xml-names/#concepts]
> [2] - [http://www.w3.org/TR/xml-names11/#concepts]
> 
> Regards,
>  CI.
> 
> ____________________
> 
> Carlos Iglesias
> 
> Fundación CTIC
> Parque Científico-Tecnológico de Gijón
> 33203 - Gijón, Asturias, España
> teléfono: +34 984291212
> email: carlos.iglesias@fundacionctic.org
> URL: http://www.fundacionctic.org 
> 
> 

-- 
Shadi Abou-Zahra - http://www.w3.org/People/shadi/ |
   WAI International Program Office Activity Lead   |
  W3C Evaluation & Repair Tools Working Group Chair |
Received on Tuesday, 2 September 2008 18:53:22 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 2 September 2008 18:53:22 GMT