W3C home > Mailing lists > Public > public-vocabs@w3.org > September 2014

Re: ItemList proposal

From: Peter Mika <pmika@yahoo-inc.com>
Date: Fri, 12 Sep 2014 12:26:10 +0000
To: "Jason Johnson (BING)" <jasjoh@microsoft.com>, Vicki Tardif Holland <vtardif@google.com>, PublicVocabs <public-vocabs@w3.org>
Message-ID: <D038B1BF.646E4%pmika@yahoo-inc.com>
Hi All,

I also took a look at the latest proposal at [1].

A couple of small suggestions:

-- We should turn itemListOrder into an Enum of fixed values (ascending, descending, unordered).
-- itemListElement currently has the range Thing or ListItem or Text, which is triple redundant ;) First, we always accept Text instead of Thing, and ListItem is a type of Thing. So the range is essentially Thing?
-- previousItem/nextItem has range ListItem. How do I capture the end of list? Is there a distinguished  NULL value?


[1] http://sdo-itemlist.appspot.com/ItemList

From: Jason Johnson <jasjoh@microsoft.com<mailto:jasjoh@microsoft.com>>
Date: Thursday, September 11, 2014 at 6:22 PM
To: Vicki Tardif Holland <vtardif@google.com<mailto:vtardif@google.com>>, PublicVocabs <public-vocabs@w3.org<mailto:public-vocabs@w3.org>>
Subject: RE: ItemList proposal
Resent-From: <public-vocabs@w3.org<mailto:public-vocabs@w3.org>>
Resent-Date: Thursday, September 11, 2014 at 6:22 PM

Property Feedback
'about' - i'm not sure i understand the necessity for this; isn't it implied by way of the contents of the list?
'author' - i like the idea of multi-type here and keeping itemlist pure rather than adding properties describe orthogonal concepts
'dataPublished' - same as above
'numberOfElements' - why is this not just calculated based on the number of elements in the list?
'ListItem' - why is this under 'Structured Value'?  IMO should be under Intangible.

Naming Feedback
1. ItemList - Change name from 'ItemList' to just 'List'.  A List implies a series / sequence of Items.  Adding 'Item' provides no semantic value.
2. ItemList - The terms ‘item’ and ‘element’ within the context of a List are synonymous.  We use both in the proposed vocabulary.  I recommend being consistent and just using one.  My person preference is to use ‘item’ and thus recommend changing 'itemListElement' to 'itemInList' and numberOfElements' to 'numberOfItems'
3. ItemList - Change name 'itemListOrder' to 'listOrder'
4. ListItem - Change name from 'itemPosition' to just 'position' and update the existing description to be 'The position of an item in a series or sequence of items'
5. ListItem - Change name from 'next' and 'previous' to 'nextItem' and 'previousItem' respectively
6. ListItem - Change the description of 'item' to 'An entity represented by an entry in a list (e.g. an 'artist' in a list of 'artists')

Other Feedback
'positionBasis' - this is really a property of the position value; the process by which it was established. The relationship exists between the position and the process by which the value was established rather than the list itself, so adding a property to the list doesn't make sense.  This concept ties into the work I've been doing around sports statistics and i recommend we hold off on implementing support for describing the basis of a position within the ItemList/ListItem proposal and instead add it as part of the new vocabulary supporting sports statistics.

From: Vicki Tardif Holland [mailto:vtardif@google.com]
Sent: Friday, September 5, 2014 10:49 AM
To: PublicVocabs
Subject: ItemList proposal

After taking people's feedback, we have put together a simpler ItemList proposal.



To allow for expressing "just a list", ItemList is now moved from being a subclass of CreativeWork to a subclass of Intangible. To support existing uses of ItemList as a CreativeWork, ItemList now contains the following properties:

- about
- author
- datePublished

Feedback is welcome.

- Vicki

Vicki Tardif Holland | Ontologist | vtardif@google.com<mailto:vtardif@google.com>
Received on Friday, 12 September 2014 12:27:10 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:29:44 UTC