W3C home > Mailing lists > Public > public-vocabs@w3.org > September 2014

RE: ItemList proposal

From: Jason Johnson (BING) <jasjoh@microsoft.com>
Date: Thu, 11 Sep 2014 16:22:26 +0000
To: Vicki Tardif Holland <vtardif@google.com>, PublicVocabs <public-vocabs@w3.org>
Message-ID: <0a205492422c4b82a04c5ee76aa211bb@DM2PR0301MB0911.namprd03.prod.outlook.com>
Property Feedback
'about' - i'm not sure i understand the necessity for this; isn't it implied by way of the contents of the list?
'author' - i like the idea of multi-type here and keeping itemlist pure rather than adding properties describe orthogonal concepts
'dataPublished' - same as above
'numberOfElements' - why is this not just calculated based on the number of elements in the list?
'ListItem' - why is this under 'Structured Value'?  IMO should be under Intangible.

Naming Feedback
1. ItemList - Change name from 'ItemList' to just 'List'.  A List implies a series / sequence of Items.  Adding 'Item' provides no semantic value.
2. ItemList - The terms ‘item’ and ‘element’ within the context of a List are synonymous.  We use both in the proposed vocabulary.  I recommend being consistent and just using one.  My person preference is to use ‘item’ and thus recommend changing 'itemListElement' to 'itemInList' and numberOfElements' to 'numberOfItems'
3. ItemList - Change name 'itemListOrder' to 'listOrder'
4. ListItem - Change name from 'itemPosition' to just 'position' and update the existing description to be 'The position of an item in a series or sequence of items'
5. ListItem - Change name from 'next' and 'previous' to 'nextItem' and 'previousItem' respectively
6. ListItem - Change the description of 'item' to 'An entity represented by an entry in a list (e.g. an 'artist' in a list of 'artists')

Other Feedback
'positionBasis' - this is really a property of the position value; the process by which it was established. The relationship exists between the position and the process by which the value was established rather than the list itself, so adding a property to the list doesn't make sense.  This concept ties into the work I've been doing around sports statistics and i recommend we hold off on implementing support for describing the basis of a position within the ItemList/ListItem proposal and instead add it as part of the new vocabulary supporting sports statistics.

From: Vicki Tardif Holland [mailto:vtardif@google.com]
Sent: Friday, September 5, 2014 10:49 AM
To: PublicVocabs
Subject: ItemList proposal

After taking people's feedback, we have put together a simpler ItemList proposal.

http://sdo-itemlist.appspot.com/ItemList

http://sdo-itemlist.appspot.com/ListItem


Details:

To allow for expressing "just a list", ItemList is now moved from being a subclass of CreativeWork to a subclass of Intangible. To support existing uses of ItemList as a CreativeWork, ItemList now contains the following properties:

- about
- author
- datePublished

Feedback is welcome.

- Vicki


Vicki Tardif Holland | Ontologist | vtardif@google.com<mailto:vtardif@google.com>

Received on Thursday, 11 September 2014 16:22:56 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:29:44 UTC