W3C home > Mailing lists > Public > public-vocabs@w3.org > May 2014

Re: VideoGame proposal

From: Dan Scott <dan@coffeecode.net>
Date: Thu, 15 May 2014 09:51:27 -0400
To: Yuliya Tikhokhod <tilid@yandex-team.ru>
Cc: public-vocabs@w3.org
Message-ID: <20140515135125.GA32111@denials>
Hi Yuliya:

On Thu, May 15, 2014 at 02:48:43PM +0400, Yuliya Tikhokhod wrote:

> This is proposal from Yandex (one of the schema.org sponsors).
> There are many sites dedicated to games (for example,
> http://store.steampowered.com/app/244850/,
> http://www.gamespot.com/eve-online/,
> https://play.google.com/store/apps/details?id=com.zeptolab.ctr2.f2p.google).
> They contain some specific information, for which we have no specific
> classes and properties in schema.org. 
> We made separate class for game as a creative work (with  complicated
> rules, characters, narrative). And called it RolePlayingGame. Maybe this
> is not a very good name and we will be thankful if you suggest better
> name for class describing games with complicated rules, fictional
> characters and specific locations. 
> Then VideoGame class is a child of two parents -  RolePlayingGame and
> SoftwareApplication. 
> We also added some additional properties to SoftwareApplication class.

This proposal certainly fills a significant gap in schema.org's mission!
Thanks for putting this together.

I do have a few comments on the proposal:

On RolePlayingGame:

* "character" (new property with a range of Person) -- it seems like this
  should be a property of CreativeWork as it could equally be applied to
  Movie, Book, TVSeries (and perhaps the range would shift to Role if
  that proposal gets sorted out)
* "location" (new property with a range of URL or Text) -- but
  http://schema.org/location already exists. I'd suggest just using that
  existing property with an additional rangeIncludes statement.
* "item" and "statistic" (new properties) are overly generic names for
  the specific role they play in schema.org; perhaps "gameItem" and
  "gameStatistic" instead?

On SoftwareApplication:

* "help" (new property with a range of URL or Text) -- how about a range
  of "CreativeWork" instead? That way, the help itself can in turn
  contain much more structured data (such as images, videos, etc). And
  of course a URL or straight Text could still be supplied for the
* "addons" (new property with a range of SoftwareApplication) -- should
  be singular, and arguably should be "addOn" (as most professional
  writing seems to use the form "add-on")
* "softwareLocalizer" (new property with a range of Person or
  Organization) points out that CreativeWork generally lacks a
  "translator" property (which is as important as the author for
  translations of literature or philosophy).

Similarly, the many, many other roles involved in creating software and
videogames (QA, graphic designers... see the long list at
http://www.gamefaqs.com/xboxone/635381-titanfall/credit) similar to
movies and comics suggests that Role is needed sooner rather than later.

On VideoGame:

* "playModes" (new property with a range of Text) -- should be singular?
  Also, the description says it can be one of three values; should this
  be made an enumeration to enable more consistent processing instead?
* "cheatCodes" (new property with a range of URL or Text) -- should be
  singular? Also feel that the range should be CreativeWork for the same
  reason as "help", above.
* "tips" (new property with a range of URL or Text) -- singular? Also
  feel that the range should be CreativeWork for the same reason as
  "help", above. And perhaps "gameTip" to avoid an overly generic name.
* "platform" (new property with a range of URL or Text) -- How about
  suggesting the use ProductOntology to unambiguously (or less
  ambiguously than Text) define the platform instead (for example,
  http://www.productontology.org/id/ColecoVision or
  http://productontology.org/id/Xbox_360 or
  http://www.productontology.org/id/Wii_U)? Also, perhaps rename this
  to "gamePlatform" to avoid an overly generic property name?

On OnlineGame:

* "serverStatus" -- it might help to make this an enumeration, given
  that there can't be _that_ many server statuses. Online, Online but
  full; Offline temporarily; Offline permanently?
* "playersNumber" -- minor, but "number" seems a bit ambiguous; maybe
  "playersOnline" or "playersOnServer"?

In the example, there is a segment called "How to win the Super Game"
that is marked up with itemprop="news" itemtype="NewsArticle". Should
the property be "tip" instead of "news"? Also, the use of NewsArticle
strengthens my conviction that we really want "CreativeWork" as the
range for "tip" and other properties :)

Thanks for this!
Received on Thursday, 15 May 2014 13:52:00 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:29:41 UTC