W3C home > Mailing lists > Public > public-vocabs@w3.org > December 2011

RE: Schema.org TV vocabulary - opening discussion

From: Evain, Jean-Pierre <evain@ebu.ch>
Date: Thu, 15 Dec 2011 18:33:08 +0100
To: 'Yves Raimond' <yves.raimond@bbc.co.uk>, Alexander Shubin <ajax@yandex-team.ru>
CC: Gregg Kellogg <gregg@kellogg-assoc.com>, Dan Brickley <danbri@danbri.org>, public-vocabs <public-vocabs@w3.org>
Message-ID: <7D1656F54141C042A1B2556AE5237D60011617D7B6E8@GVAMAIL.gva.ebu.ch>
Hello Alexander, Yves, all,

My comments not in line for readability

1/ Seasons and episodes vs. season and episode (singular)

I believe singular is better. This is the right level of granularity.

Take for example: 
- episodes (group) arePartOf Series (series is plural but is A group of episodes) -> this works but
- episodes (group) arePartOf Seasons (here groups of episodes) -> then what episode goes in what season
We can develop several similar examples like above.
It is simpler and more accurate to simple say that an episode isPartOf Season and Season isPartOfSeries, etc.

If there is a need to define e.g. an rdf:list of episodes then why not add a call episodeList with hasMember episode in order to not confuse all the concepts

[[One of my favourite quotes these days would apply here -> keep things as simple as possible.... but not simpler!!]]

2/ Properties of Programme and Clip -> yes of course :-)

3/ reuse Event properties -> fine

However, if you look at the use of endDate in Series/Season and the notion of "last first" publication (further down this thread and discussion with Gregg), we need to be careful and make sure that startDate and endDate effectively continue to cover the initial semantic of their use related to an Event, hence its reuse for broadcast times.

4/ TimePeriod

This property is more to address DC-Like coverage information like a time period (e.g. historical) that the programme content may relate to. It is therefore semantically different from the event start and end times



-----Original Message-----
From: yves.raimond@gmail.com [mailto:yves.raimond@gmail.com] On Behalf Of Yves Raimond
Sent: samedi, 10. décembre 2011 20:58
To: Alexander Shubin
Cc: Gregg Kellogg; Dan Brickley; public-vocabs; Evain, Jean-Pierre
Subject: Re: Schema.org TV vocabulary - opening discussion

Hello Alexander!

Thanks for all the detailed comments!

> Hi Dan, all,
> Some questions:
> *
>>In Series:
>>Rename 'episodes' into 'episode' (object is a single Episode with a position, not a list - confusing in the current spec)
>>Rename 'seasons' into 'season'
>>In Season:
>>Rename 'episodes' to 'episode'
> Could you explain why should we rename these properties? As far as I understand it may be several seasons in series and several episodes in series and season as well? Am I mistaken?

See my email to Gregg. The spec, at the moment, doesn't make it clear
what the range of those properties is supposed to be (a list? a
individual episode?)

> *
>>Add Thing > CreativeWork > Programme
> Don't we want to add some special properties for programme? Smth like anchorperson, duration, ...

Yes, that's the point of the "Move all properties" item in the list of
proposed changes.

> * Add Thing > CreativeWork > Clip
> The same question. Can we add some specific properties for Clip type?
> * > Add Thing > TimePeriod
> What is TimePeriod? I mean is it smth more than mere ISO 8601 Time Intervals (http://en.wikipedia.org/wiki/ISO_8601#Time_intervals)?

Agreed - that's one for Jean-Pierre. I would be happy with an ISO time
interval on the service.

> * > Add 'broadcastOf' property, range 'Clip' or 'Episode', (JP) or Programme (also rename broadcastOf in 'source')
> Agree with renaming.
> *
>> Add Thing > Event > Broadcast
>> Add 'broadcastOn' property, range 'Service'
>> Add 'broadcastOf' property, range 'Clip' or 'Episode', (JP) or Programme (also rename broadcastOf in 'source')
>> Add 'start', range date
>> Add 'end', range date
> What is the semantic of new 'start' and 'end' properties? We already have 'startDate' and 'endDate' in Event and 'period' property in Service. What is the difference from them?

You're right - we should use the properties inherited from Event. I
removed those two lines from the proposal.

> * > Add contentTimePeriod, range 'TimePeriod'
> The same question. Is it different from 'period' property of 'broadcastOn' (Service)?

Yes - see above.


> ----
> Best Regards,
> Alex
> Yandex.com
> -----Original Message-----
> From: Gregg Kellogg [mailto:gregg@kellogg-assoc.com]
> Sent: Saturday, December 10, 2011 2:31 AM
> To: Dan Brickley
> Cc: public-vocabs; Evain, Jean-Pierre; Yves Raimond
> Subject: Re: Schema.org TV vocabulary - opening discussion
> In Series/Season:
> [[[
> Modify 'endDate' description to be 'start of the last first publication of an episode within that series/season'
> ]]]
> "last first publication"? Perhaps just "last publication".
> Regarding moving TVSeries (for example) under Series. Do you expect to publish schema:TVSeries rdfs:subClassOf schema:Series? This is really a broad question for all hierarchical classes.
> Also, is it expected that the range of schema:episode is an rdf:List? How about an OWL restriction on the cardinality of schema:episode? What is the strategy for indicating that some properties really relate to an ordered collection? This was suggested in the Microdata to RDF mapping for the following properties as well [1]:
> blogPosts, breadcrumb, episodes, events, itemListElement, musicGroupMember, seasons, ...
> Really, just an example for how to treat properties that should take an RDF Collection, as this is the data-model that the microdata JSON encoding would take.
> Gregg
> [1] https://dvcs.w3.org/hg/htmldata/raw-file/default/microdata-rdf/index.html#example-registry
> On Dec 9, 2011, at 9:09 AM, Dan Brickley wrote:
>> Following up on the discussion here a few weeks ago, around
>> Schema.org's TV vocabulary (see
>> http://lists.w3.org/Archives/Public/public-vocabs/2011Oct/0095.html
>> and nearby)
>> This work has moved along a bit, many thanks to Jean-Pierre (EBU) and
>> to Yves and others at the BBC for their investigations and
>> collaboration.
>> The work-in-progress results are linked from our Wiki homepage
>> http://www.w3.org/wiki/WebSchemas as
>> http://www.w3.org/wiki/TVRadioSchema and are a set of additions and
>> edits that would help improve this area of schema.org.  While it's not
>> a fully polished proposal with use cases and explanations for
>> everything, I think it's worth drawing wider attention to it at this
>> point.
>> The first thing it does is provide a home for radio alongside TV, as
>> well as basics for better supporting description of clips, and
>> broadcasts. Yves and Jean-Pierre might want to say more.
>> If you're interested in helping improve schema.org's coverage of these
>> topics, do please take a look at http://www.w3.org/wiki/TVRadioSchema
>> and comment here or in the wiki...
>> cheers,
>> Dan
Received on Thursday, 15 December 2011 17:43:12 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:29:21 UTC