W3C home > Mailing lists > Public > public-tt@w3.org > June 2015

Re: [webvtt] Rename "line position" to "line offset". (#194)

From: Nigel Megitt <nigel.megitt@bbc.co.uk>
Date: Wed, 10 Jun 2015 09:03:42 +0000
To: Silvia Pfeiffer <silviapfeiffer1@gmail.com>, David Singer <singer@apple.com>
CC: W3C Public TTWG <public-tt@w3.org>, Philip Jägenstedt <philipj@opera.com>
Message-ID: <D19DBB4C.218FE%nigel.megitt@bbc.co.uk>


On 10/06/2015 01:12, "Silvia Pfeiffer" <silviapfeiffer1@gmail.com> wrote:

>On Wed, Jun 10, 2015 at 7:19 AM, David Singer <singer@apple.com> wrote:
>>
>>> On Jun 9, 2015, at 13:09 , Silvia Pfeiffer <silviapfeiffer1@gmail.com>
>>>wrote:
>>>
>>> [not sure why this thread suddenly included the TTWG - it was merely
>>> on the github bug before for WebVTT]
>>
>> I was hoping to raise its visibility, in that I knew that my idea
>>(below, critiqued) was weak, but maybe someone else had a better idea…
>
>If somebody has a better idea for a term that an offset from the top
>for describing the positioning of a box of lines from the top of the
>video viewport, that would be helpful. I still believe "offset" works
>better than "position" for this case.

I thought part of the problem we are trying to solve is that the offset
direction is dependent on the writing direction, so the offset might be
from the left for vertical writing or the top for horizontal writing.
That's why I proposed the terms inline and block. If that's not the case
then why don't we just use "position-horizontal" and "position-vertical"
respectively?

>
>
>>> I don't think those concepts are what we're actually dealing with.
>>> Leading is the whitespace between lines
>>> (http://en.wikipedia.org/wiki/Leading),
>>
>> well, or the whitespace before a paragraph, which is closer this
>>meaning.  It has at least the advantage of being in the block
>>progression dimension.
>
>I've not seen "leading" used for whitespace offset in block
>progression. "Line leading" reads a bit harder than "line offset",
>too.
>
>
>>> not the distance from the top
>>> of the page (which is what our "line" setting provides). Indent may
>>> have worked, but we're already using "position”.
>>
>> yup.  major name changes might be confusing…
>
>We should stick with "line" and "position" as the names, but we're
>after better words for describing what they mean.

I'd be happy to change the names - I think they're where the confusion
begins for newcomers. Accepted it would also create confusion for those
who are used to the current terminology.

Nigel

>
>Thanks,
>Silvia.



-----------------------------
http://www.bbc.co.uk

This e-mail (and any attachments) is confidential and
may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in
error, please delete it from your system.
Do not use, copy or disclose the
information in any way nor act in reliance on it and notify the sender
immediately.
Please note that the BBC monitors e-mails
sent or received.
Further communication will signify your consent to
this.
-----------------------------
Received on Wednesday, 10 June 2015 09:04:19 UTC

This archive was generated by hypermail 2.3.1 : Thursday, 5 October 2017 18:24:23 UTC