W3C home > Mailing lists > Public > public-tt@w3.org > June 2015

Re: [webvtt] Rename "line position" to "line offset". (#194)

From: Silvia Pfeiffer <silviapfeiffer1@gmail.com>
Date: Wed, 10 Jun 2015 10:12:48 +1000
Message-ID: <CAHp8n2kcm8e0NPiUuWrTDRYZTqsxst0TQyj+3WV_xqEjedXx=Q@mail.gmail.com>
To: David Singer <singer@apple.com>
Cc: Nigel Megitt <nigel.megitt@bbc.co.uk>, W3C Public TTWG <public-tt@w3.org>, Philip Jägenstedt <philipj@opera.com>
On Wed, Jun 10, 2015 at 7:19 AM, David Singer <singer@apple.com> wrote:
>
>> On Jun 9, 2015, at 13:09 , Silvia Pfeiffer <silviapfeiffer1@gmail.com> wrote:
>>
>> [not sure why this thread suddenly included the TTWG - it was merely
>> on the github bug before for WebVTT]
>
> I was hoping to raise its visibility, in that I knew that my idea (below, critiqued) was weak, but maybe someone else had a better idea…

If somebody has a better idea for a term that an offset from the top
for describing the positioning of a box of lines from the top of the
video viewport, that would be helpful. I still believe "offset" works
better than "position" for this case.


>> I don't think those concepts are what we're actually dealing with.
>> Leading is the whitespace between lines
>> (http://en.wikipedia.org/wiki/Leading),
>
> well, or the whitespace before a paragraph, which is closer this meaning.  It has at least the advantage of being in the block progression dimension.

I've not seen "leading" used for whitespace offset in block
progression. "Line leading" reads a bit harder than "line offset",
too.


>> not the distance from the top
>> of the page (which is what our "line" setting provides). Indent may
>> have worked, but we're already using "position”.
>
> yup.  major name changes might be confusing…

We should stick with "line" and "position" as the names, but we're
after better words for describing what they mean.

Thanks,
Silvia.
Received on Wednesday, 10 June 2015 00:13:38 UTC

This archive was generated by hypermail 2.3.1 : Thursday, 5 October 2017 18:24:23 UTC