W3C home > Mailing lists > Public > public-sysapps@w3.org > May 2013

RE: Rename "Web Alarms API" to "Task Scheduler"

From: Christophe Dumez - SISA <ch.dumez@partner.samsung.com>
Date: Tue, 21 May 2013 12:25:56 +0000
To: Marta Pawlowska <m.pawlowska@samsung.com>, 'Filip Maj' <fil@adobe.com>, 'Hsin-Yi Tsai' <htsai@mozilla.com>, 'Mounir Lamouri' <mounir@lamouri.fr>
CC: "public-sysapps@w3.org" <public-sysapps@w3.org>
Message-ID: <1147D1694C8E994D99943F21EC61E97F010F4A46@sisaex02sj>
Ok, given the feedback on the mailing list. I'll make a pull request to proceed with the renaming proposed by Mounir.

Kr,
Christophe DUMEZ.
________________________________________
From: Marta Pawlowska [m.pawlowska@samsung.com]
Sent: Friday, May 17, 2013 12:19
To: 'Filip Maj'; 'Hsin-Yi Tsai'; 'Mounir Lamouri'
Cc: public-sysapps@w3.org
Subject: RE: Rename "Web Alarms API" to "Task Scheduler"

+1 for new name

-----Original Message-----
From: Filip Maj [mailto:fil@adobe.com]
Sent: Thursday, May 16, 2013 4:30 AM
To: Hsin-Yi Tsai; Mounir Lamouri
Cc: public-sysapps@w3.org
Subject: Re: Rename "Web Alarms API" to "Task Scheduler"

+1

On 5/15/13 7:27 PM, "Hsin-Yi Tsai" <htsai@mozilla.com> wrote:

>+ 1 to renaming
>
>On 2013年05月16日 00:01, Mounir Lamouri wrote:
>> Hi,
>>
>> I would like to start a few discussions regarding the outstanding issues
>> we currently have with the Alarm API. To keep things simpler, I will
>> restrict every thread to one topic.
>>
>> First of all, we should change the name of this specification. I think
>> that everybody will agree that the name is terrible, doesn't reflect
>> what we want to do and let people believe it is trying to do things it
>> isn't really designed for.
>>
>> To start the discussion, I would like to propose to rename the
>> specification "Task Scheduler". Task is unfortunately used in other
>> specifications like HTML [1] but the naming isn't too overloaded and the
>> closest name I can think of would be "event" which is way too much used
>> in the Web Platform.
>>
>> If the specification is renamed "Task Scheduler", I think we should
>> rename the "Alarm" interface "ScheduledTask".
>>
>> Any thoughts on this?
>>
>> [1]
>>
>>http://www.whatwg.org/specs/web-apps/current-work/multipage/webappapis.ht
>>ml#event-loops
>>
>> Thanks,
>> --
>> Mounir
>>
>
>--
>Hsin-Yi Tsai 蔡欣宜
>Mozilla Taiwan
>T: +886-2-87861100 ext:312
>htsai@mozilla.com
>
>
Received on Tuesday, 21 May 2013 12:26:31 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:36:13 UTC