W3C home > Mailing lists > Public > public-swd-wg@w3.org > September 2008

ISSUE-130: Last Call Comment: skos:hasTopConcept and skos:topConceptOf

From: SWD Issue Tracker <dean+cgi@w3.org>
Date: Tue, 30 Sep 2008 10:57:53 +0000 (UTC)
To: public-swd-wg@w3.org,public-rdf-in-xhtml-tf@w3.org
Message-Id: <20080930105753.B15721535E4@plopper.w3.org>

ISSUE-130: Last Call Comment: skos:hasTopConcept and skos:topConceptOf


Raised by: Alistair Miles
On product: SKOS

Raised by Kjetil Kjernsmo in [1]:

We have defined a 
sub:isMainConceptOf  a owl:ObjectProperty ; 
            rdfs:range skos:ConceptScheme ;
            rdfs:domain skos:Concept ;
            owl:inverseOf skos:hasTopConcept . 
so it was great to see that skos:topConceptOf is in! Please keep it there, it 
is simply much easier for us to use it in development with the present 

I haven't followed the debate since this first was debated, but I would like 
to bring this up again: I do not like the naming of skos:hasTopConcept and 
skos:topConceptOf. As long as there are associative relationships in the 
system, it seems meaningless to make the hierarchical relationships more 
prominent than the associative by connecting this property to the hierarchy. 

So, that's why I called my inverse of skos:hasTopConcept isMainConceptOf. I 
think something like that would be better. 

I haven't thought too carefully about it, but what if:

<S> rdf:type skos:ConceptScheme ;
  skos:hasTopConcept <B> .

<B> rdf:type skos:Concept .

<A> rdf:type skos:Concept ;
        skos:related <B> .

would this be consistent?

I think that's fairly inevitable in our system, and it would certainly break 
things if we couldn't do this. What if <B> skos:broader <C> . ?

Requires discussion.

[1] http://lists.w3.org/Archives/Public/public-swd-wg/2008Sep/0015.html 
Received on Tuesday, 30 September 2008 10:58:28 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:07:54 UTC