W3C home > Mailing lists > Public > public-svg-wg@w3.org > January to March 2013

Re: Broken links in SVG2, problems building

From: Chris Lilley <chris@w3.org>
Date: Thu, 21 Mar 2013 16:35:08 +0100
Message-ID: <7110272704.20130321163508@w3.org>
To: "Erik Dahlstrom" <ed@opera.com>
CC: public-svg-wg@w3.org
Hello Erik,

Thursday, March 21, 2013, 4:25:38 PM, you wrote:

> On Wed, 20 Mar 2013 14:59:31 +0100, Chris Lilley <chris@w3.org> wrote:

>> Hello folks
>>
>> Firstly, apologies for taking a long time to get a build environment
>> going. Cygwin sucks and my new laptop seems incompatible with every
>> linux distribution I have tried (videocard and ssd hard disk).
>>
>> While I continue to work on that, I could use some help in fixing then
>> rebuilding SVG2 spec to make it ready for publication.
>>
>> validity:
>>   easy, change <acronym> to <abbr> in the copyright statement (three
>>   places) for HTML5 validity.

> I've now fixed that in svg2-tools. Note that it was the pubrules checker
> that suggested the <acronym> markup in the first place :)

Yes (for HTML4 and XHTML1). But the html5 validator complains.
Thanks for fixing the tools.

>> broken links:
>>   a lot, especially to the masking chapter. List of broken links
>>   attached.

> Let's try to get that sorted out as quickly as possible.

I suspect that some edits have changed IDs in the masking chapter,
causing most of the broken fragment links. If that was inadvertent,
restoring the IDs would fix them. If spec text has been removed
however, then all the other sections that link to it need to be
edited.



-- 
Best regards,
 Chris                            mailto:chris@w3.org
Received on Thursday, 21 March 2013 15:35:10 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:20:16 UTC