W3C home > Mailing lists > Public > public-svg-wg@w3.org > January to March 2010

Re: SVG 1.1F2 testsuite update

From: Anthony Grasso <anthony.grasso@cisra.canon.com.au>
Date: Mon, 15 Mar 2010 20:04:56 +1100
Message-ID: <4B9DF838.2070509@cisra.canon.com.au>
To: Erik Dahlstrom <ed@opera.com>
CC: "public-svg-wg@w3.org" <public-svg-wg@w3.org>
Hi Erik,

I've started putting a dent in that list of issues with the testsuite. Please 
see comments below.

Erik Dahlstrom wrote:
> 
> Hello svg-wg,
> 
> I've just finished my run over the 1.1F2 testsuite, fixing a bunch of
> issues in the process. I've noted some of the still unfixed things below.
> 
> General comments:
> - The old testcase descriptions are not up-to-date with the new template,
> we need to decide how to proceed.
> - We need a disclaimer somewhere for the tests that are in draft status,
> on main page maybe? Or on each page that contains a draft test?
> - Note to self: I made a few mistakes when checking in some of the new
> references, I need to make sure they all have the -kb flag.
> 
> animate-elem-24-t.svg
> seems to have lost its svgfont in the template converstion process
FIXED - Basically due to a flaw in the conversion script.

> 
> animate-elem-42-t.svg
> animate-elem-43-t.svg
> animate-elem-45-t.svg
> animate-elem-47 - up to ...51-t.svg
> empty tests
FIXED - removed tests.

> 
> animate-elem-60-t
> reference image should probably show all rects as green, so needs
> patchimage
FIXED - created an image patch for this.

> 
> animate-elem-77-t.svg
> needs italic and bold faces for the SVGFreeSans svgfont
I think this was already fixed when I looked at it

> 
> color-prop-04-t.svg
> color-prop-05-t.svg
> is accepted but has the draft mark
FIXED - commented out the draft watermark.

> 
> conform-viewers-01-t.svg
> needs reference image
FIXED - checked one in. Although, I'm just wondering if we need an image patch 
for this. The Batik squiggle viewer seems to render this file correctly.

> 
> coords-viewattr-01-b.svg
> needs reference image, needs imagepatch
> 
FIXED - checked in a PNG image patch. Once again, the Batik squiggle viewer 
seems to render this file correctly.

> filters-blend-01-b.svg
> wrong scale on viewbox? both svg and reference wrong
Already fixed.

> 
> filters-color-02-b.svg
> filters-conv-02-f.svg
> filters-light-02-f.svg
> reference has draft mark, but otherwise looks ok
FIXED - checked in new reference images for these. Will we need image patches 
for these as well?

> 
> filters-felem-02-f.svg
> filters-offset-02-b.svg
> needs imagepatch
FIXED - checked in an imagepatch for each test.

> 
> filters-turb-02-f.svg
> no reference image checked in
> 
> fonts-kern-01-t.svg
> svgfonts missing, conversion problem probably
> 
> interact-pevents-01-b.svg
> interact-pevents-02-t.svg
> interact-pevents-03-t.svg
> interact-pevents-04-t.svg
> interact-pevents-05-b.svg
> needs imagepatch
> 
> linking-a-06-t.svg
> empty test
> 
> painting-marker-06-f.svg
> needs to be reviewed, looks straightforward (passes in ff3.5 and
> opera10.10, fails in safari4)
> 
> painting-render-02-b.svg
> draft, needs review by AG
> 
> painting-stroke-05-t.svg
> is accepted but still has draft mark, needs pass criteria
> 
> painting-stroke-06-t.svg
> is accepted but has draft mark, needs operator script
> 
> paths-data-11-t.svg
> empty test
> 
> paths-data-16-t.svg
> needs new reference png checked in, looks ok apart from draft mark
> 
> paths-dist-01-t.svg
> empty test
> 
> paths-dom-01-f.svg
> needs me to finish writing the test, and then review, some browser diffs
> here
> 
> pservers-grad-08-b.svg
> seems to have lost the svgfont in the conversion, looks very different
>     from the old testsuite image, see
> http://www.w3.org/Graphics/SVG/Test/20061213/htmlEmbedHarness/full-pservers-grad-08-b.html 
> 
> 
> pservers-grad-20-b.svg
> has a correct imagepatch, but the test hasn't been reviewed yet (takers?)
> 
> render-elems-06-t.svg
> render-elems-07-t.svg
> render-elems-08-t.svg
> has lost svgfont in conversion
> 
> script-specify-01-f.svg
> script-specify-02-f.svg
> needs reviewer, I added the missing draft watermark
> 
> struct-dom-04-b.svg
> struct-dom-05-b.svg
> needs to be repaired like struct-dom-02-b.svg and get a similar imagepatch
> 
> struct-dom-12-b.svg
> looks ready has been reviewed, I've made a patchimage, can it be marked as
> accepted?
> 
> styling-css-02-b.svg
> styling-css-03-b.svg
> styling-css-04-f.svg
> styling-css-05-b.svg
> styling-css-06-b.svg
> styling-elem-01-b.svg
> styling-pres-01-t.svg
> styling-pres-02-f.svg
> text-align-01-b.svg
> text-align-02-b.svg
> text-align-03-b.svg
> text-align-04-b.svg
> text-align-05-b.svg
> text-align-06-b.svg
> text-align-07-t.svg
> text-align-08-b.svg
> text-altglyph-01-b.svg
> text-altglyph-02-b.svg
> text-dom-01-f.svg
> text-fonts-01-t.svg
> text-fonts-02-t.svg
> text-fonts-03-t.svg
> text-fonts-04-t.svg
> text-intro-01-t.svg
> text-intro-02-t.svg
> text-intro-03-t.svg
> text-intro-04-t.svg
> text-intro-05-t.svg
> text-intro-06-t.svg
> text-path-01-b.svg
> needs reference image
> 
> text-deco-01-b.svg
> original should use svgfont instead, reference missing some text because
> of that
> 
> text-spacing-01-b.svg
> text-text-01-b.svg
> text-text-03-b.svg
> needs reference image, testcase looks too small, missing viewbox?
> 
> text-text-04-t.svg
> needs reference image, broken svgfont
> 
> text-text-05-t.svg
> text-text-06-t.svg
> text-tref-01-b.svg
> text-tselect-01-b.svg
> text-tselect-02-f.svg
> text-tspan-01-b.svg
> needs reference image
> 
> text-tspan-02-b.svg
> text-ws-03-t.svg
> types-dom-02-f.svg
> types-dom-04-b.svg
> types-dom-05-b.svg
> types-dom-06-f.svg
> needs patchimage + reference image
> 
> text-ws-01-t.svg
> text-ws-02-t.svg
> types-dom-01-b.svg
> needs reference image
> 
> Cheers
> /Erik
> 
Received on Monday, 15 March 2010 09:05:37 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:20:11 UTC