W3C home > Mailing lists > Public > public-svg-wg@w3.org > October to December 2008

Throwing INVALID_ACCESS_ERR when setting <use xlink:href="">

From: Cameron McCormack <cam@mcc.id.au>
Date: Fri, 24 Oct 2008 15:02:18 +1100
To: public-svg-wg@w3.org
Message-ID: <20081024040218.GF16875@arc.mcc.id.au>

Hello WG.

The spec currently says, in the description of when setTraitNS() throws
an INVALID_ACCESS_ERR DOMException:

  Raised if the input value is an invalid value for the given trait or
  null is specified.  This exception is also thrown when the 'use'
  element is hooked into the document tree and the the value of
  'xlink:href' is set invalid.
   — http://dev.w3.org/SVG/profiles/1.2T/publish/svgudom.html#svg__TraitAccess_setTraitNS

In the “note about invalid/unsupported trait values” section, it says
that INVALID_ACCESS_ERR is thrown whenever an unsupported value is set
for the trait.  It doesn’t mention anything about whether the element is
in the document tree or not, however.

Given that the sentence mentioning @xlink:href on <use> describes a
subset of the situations when the exception would be thrown anyway, due
to the other section, I think it should be removed, as it could mislead
people into thinking that the exception is not thrown if the element is
not in the tree.

Thanks,

Cameron

-- 
Cameron McCormack ≝ http://mcc.id.au/
Received on Friday, 24 October 2008 04:02:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 24 October 2008 04:03:00 GMT