Re: A Social API (and Federation Protocol) Proposal

On 11/05/2014 05:22 AM, James M Snell wrote:
> On Tue, Nov 4, 2014 at 5:49 PM, ☮ elf Pavlik ☮
> <perpetual-tripper@wwelves.org> wrote:
> [snip]
>> I gave it very quick (late night) read. I noticed use of objectType and
>> objectTypes in Straems. Can you explain little more use of objectTypes
>> (plural)?
>> I find objectTypes appearing in draft only in excerpt below:
>> [snip]
> 
> The "objectTypes" property is a bit of a kludge documented in the Base
> Schema doc (https://github.com/activitystreams/activity-schema/blob/master/activity-schema.md)
> used to provide a hint as to the types of objects contained in a
> collection.
what do you think about IMO clearer naming:

        {
          "id": "https://example.com/~alice/my-stream",
          "objectType": "collection",
          "objectTypes": ["activity"]
          "items": [ ... ]
        }

vs

        {
          "id": "https://example.com/~alice/my-stream",
          "type": "Collection",
          "memberType": ["Activity"]
          "member": [ ... ]
        }

and unless we have reason to define memberType as owl:FunctionalProperty
we also need to explain behavior in case of multiple types eg.

       "memberType": ["Person", "Organization"]

if you prefer using items and itemType or itemsType one can always remap
it in context so we can stay rather liberal with terminology but we
could at least try to stay careful with suggesting cardinality with
plural names of properties / predicates .

Received on Wednesday, 5 November 2014 22:21:47 UTC