W3C home > Mailing lists > Public > public-sml@w3.org > August 2009

[Bug 7252] New: XLink Note should be updated to refer to XLink 1.1

From: <bugzilla@wiggum.w3.org>
Date: Mon, 10 Aug 2009 16:58:31 +0000
To: public-sml@w3.org
Message-ID: <bug-7252-1927@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=7252

           Summary: XLink Note should be updated to refer to XLink 1.1
           Product: SML
           Version: unspecified
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Keywords: editorial, externalComments
          Severity: normal
          Priority: P2
         Component: EPR Reference Scheme
        AssignedTo: kirk.wilson@ca.com
        ReportedBy: johnarwe@us.ibm.com
         QAContact: public-sml@w3.org
                CC: pgrosso@ptc.com


The XML Core wg emailed in the following comments.
Original URI: http://lists.w3.org/Archives/Public/public-sml/2009Jul/0000
Contents reproduced here, part:

the XML Core WG proposes that you redefine the 
SML XLink Reference Scheme to use XLink 1.1 rather than XLink 1.0.

In XLink 1.1, the xlink:type attribute with value "simple" is optional,
provided that an xlink:href attribute is present.  Moving to XLink 1.1
would require the following editorial actions to your document:

1) Remove item 1a from Section 2.

2) Add a new item 2c to Section 2, thus:

   c.  If an attribute information item whose [local name] is type,
   whose [namespace name] is http://www.w3.org/1999/xlink is present,
   its content is the string "simple".

3) Update at least one example to remove the xlink:type attribute.

4) Update the References section to refer to XLink 1.1.

5) Optionally add a claim of XLink 1.1 simple conformance.  ("Simple
conformance" is a new term, and means that you understand simple links
but not extended links.)

paul

Paul Grosso for the XML Core WG



On its telecon of 2009-08-10, the SML working group agreed to make the
requested updates.


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Monday, 10 August 2009 16:58:41 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 10 August 2009 16:58:42 GMT