Re: Fetch API

On Thu, May 29, 2014 at 4:58 PM, Marcos <marcos@marcosc.com> wrote:

>
> > enum RequestMode { "same-origin", "tainted cross-origin", "CORS",
> "CORS-with-forced-preflight" };
>
> I think these are badly named (even though they use the names used in HTML
> and Fetch). It's going to be annoying to type these out for developers.
>
> I would change them to:
> enum RequestMode { "same-origin", "cors", "cors-tainted", "cors-preflight"
> };
>

I like those better.

We want consistency with lowercasing or uppercasing cors/CORS in enums,
though.

--tobie

Received on Thursday, 29 May 2014 15:11:09 UTC