W3C home > Mailing lists > Public > public-script-coord@w3.org > July to September 2013

[Bug 20020] Support subclassing Array

From: <bugzilla@jessica.w3.org>
Date: Thu, 12 Sep 2013 17:44:55 +0000
To: public-script-coord@w3.org
Message-ID: <bug-20020-3890-RfILkvkOi3@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=20020

Garrett <dhtmlkitchen@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |dhtmlkitchen@gmail.com

--- Comment #2 from Garrett <dhtmlkitchen@gmail.com> ---
(In reply to Anne from comment #1)
> In http://dom.spec.whatwg.org/#elements we want Elements.prototype.queryAll
> to return this.constructor ideally.
>
That is a terrible name. You have interfaces Elements and Element. Can you
rename Elements to ElementList?

And the parameter name is plural, too, though it replresents a string. Can we
instead call that relativeSelectorText?

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Thursday, 12 September 2013 17:45:00 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:37:50 UTC