[Bug 14878] Rename const to legacyconst

http://www.w3.org/Bugs/Public/show_bug.cgi?id=14878

--- Comment #16 from Brendan Eich <brendan@mozilla.org> 2011-11-23 19:21:32 UTC ---
(In reply to comment #15)
> For dense sets in [0,31], bitfields are still more verbose and less usable. 
> You have
> 
>   if (foo & Foo.a & Foo.b & ~Foo.c & Foo.d)
> vs.
>   if (foo.a && foo.b && !foo.c && foo.d)

Read what I wrote again: union, intersection, differencing. I never write
"membership testing". Yeesh.

Your overlong comment ignores actual use-cases of numeric consts in WebIDL,
notably https://www.khronos.org/registry/webgl/specs/1.0/.

Do not impose policy at the level of mechanism.

/be

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Received on Wednesday, 23 November 2011 19:21:42 UTC