W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2011

[Bug 14878] Rename const to legacyconst

From: <bugzilla@jessica.w3.org>
Date: Tue, 22 Nov 2011 06:27:44 +0000
To: public-script-coord@w3.org
Message-Id: <E1RSjpY-0000z2-1b@jessica.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=14878

--- Comment #12 from Yehuda Katz <wycats@gmail.com> 2011-11-22 06:27:43 UTC ---
Why are bitmasks superior to boolean properties?

(In reply to comment #11)
> (In reply to comment #10)
> > Bitmasks are not a good user-facing API for JavaScript. Anecdotally, SproutCore
> > 1.x used bitmasks for some state management code in our data store API, and it
> > was one of the most confusing (and "weird") parts of that API.
> 
> Can you say more? What were people confused about? If it's the botched C
> operator precedence heritage, that's informative -- that poisons the whole
> well.
> 
> > Is there anything lost by simply using String literals for this purpose? As a
> > practitioner, I agree with Anne that constant/bitmask APIs are more annoying to
> > use, and don't seem to offer any obvious gain other than the emotional appeal
> > of cargo-culting a C best practice.
> 
> Use cargo culting properly. There are no fake airplanes here, flags and bitwise
> operators work. The question is about usability, not sentiment or
> pre-scientific pattern-matching.
> 
> /be

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Tuesday, 22 November 2011 06:29:09 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 May 2013 19:30:05 UTC