W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2011

[Bug 14878] Rename const to legacyconst

From: <bugzilla@jessica.w3.org>
Date: Mon, 21 Nov 2011 19:37:38 +0000
To: public-script-coord@w3.org
Message-Id: <E1RSZgQ-0001qQ-Gk@jessica.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=14878

Brendan Eich <brendan@mozilla.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |brendan@mozilla.org

--- Comment #5 from Brendan Eich <brendan@mozilla.org> 2011-11-21 19:37:38 UTC ---
(In reply to comment #4)
> Const was a bad idea. Developers do not like bitmask APIs.

Evidence?

It's a bit extreme, since JS has |, &, and ^, and it's hard to beat those if
you have a small enough set (union, intersection, difference).

Is there a usability problem that JS developers don't face, that is inflicted
here by some combo of WebIDL and JS?

/be

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Monday, 21 November 2011 19:37:48 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 May 2013 19:30:05 UTC