W3C home > Mailing lists > Public > public-rif-wg@w3.org > June 2008

Re: a few comments about DTB

From: Jos de Bruijn <debruijn@inf.unibz.it>
Date: Tue, 17 Jun 2008 08:43:50 +0200
Message-ID: <48575D26.7080203@inf.unibz.it>
To: Chris Welty <cawelty@gmail.com>
CC: Axel Polleres <axel.polleres@deri.org>, "Public-Rif-Wg (E-mail)" <public-rif-wg@w3.org>

>>>>> Here are a few things I noticed in the DTB document during the 
>>>>> meeting:
>>>>>
>>>>> - you use DATATYPE sometimes as the IRI of a datatype and sometimes 
>>>>> as a
>>>>> non-IRI name of a datatype.  It is unclear what the relationship is
>>>>> between these two names, especially since according to section 2.2 the
>>>>> names of the data types are IRIs.  In addition, the names are not 
>>>>> always
>>>>> what one would expect.  For example, I would expect the short name of
>>>>> the xs:string datatype to be "string".  However, in section 4.1 and 
>>>>> 4.2
>>>>> it seems to be "String".
>>>>> I guess it probably makes sense to use some kind of short names for 
>>>>> the
>>>>> datatypes in the names of certain predicates, but the relationship 
>>>>> needs
>>>>> to be defined.
>>>>
>>>> I added respecting paragraphs in 4.1 and 4.2 explaining the naming 
>>>> convention.
>>>>
>>>> "As a naming convention we use the non-prefix NCNAME part denoting 
>>>> the data type in CamelCase, for instance we use pred:isString for 
>>>> the guard predicate for xsd:string, or pred:isText for the guard 
>>>> predicate for rif:text. Other RIF dialects involving new datatypes 
>>>> not mentioned in the present document MAY follow this convention 
>>>> where applicable without creating ambiguities with predicate names 
>>>> defined in the present document."
>>>
>>> I'm not sure this is sufficient; specifically, you do not define what 
>>> the labels are for any of the datatypes, you only include some 
>>> examples.  I think we need to define the concept of a "label" for 
>>> datatypes, and the labels for the XML schema datatypes should be 
>>> mentioned explicitly.
>>> Then, I am not convinced about the naming convention.  Why not just 
>>> capitalize the first character? the camel case convention seems 
>>> overly invasive.
>>
>> what about e.g. "is-string"? better?
> 
> I'm not sure Jos is talking about the names of the guard predicates, but 
> actually I don't know exactly what he means by a "label for datatypes".  
> Are you talking, Jos, about something informal to use in the English 
> text of the document to describe the datatype, e.g. "xsd:string is the 
> datatype for strings"?

No, with "label" I mean the short name for datatypes included in the 
names of guard predicates.  For example, the xs:string would have the 
label "string" or "String".

Best, Jos

> 
> -Chris
> 

-- 
                          debruijn@inf.unibz.it

Jos de Bruijn,        http://www.debruijn.net/
----------------------------------------------
One man that has a mind and knows it can
always beat ten men who haven't and don't.
   -- George Bernard Shaw



Received on Tuesday, 17 June 2008 10:03:33 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 2 June 2009 18:33:49 GMT