W3C home > Mailing lists > Public > public-rdfa-wg@w3.org > May 2010

Re: RDFa DOM API (Fully merged)

From: Manu Sporny <msporny@digitalbazaar.com>
Date: Thu, 20 May 2010 00:38:52 -0400
Message-ID: <4BF4BCDC.2030005@digitalbazaar.com>
To: RDFa WG <public-rdfa-wg@w3.org>
On 05/19/2010 08:36 AM, Toby Inkster wrote:
> On Wed, 19 May 2010 00:08:28 -0400
> Manu Sporny <msporny@digitalbazaar.com> wrote:
>> http://www.w3.org/2010/02/rdfa/sources/rdfa-dom-api/
> I really don't like some of the method names.

Should we put aside a month to bike-shed the names :P

Mark and I discussed if Property Group should be called something else
for hours. Web Object vs. Expando vs. Webble vs. Item vs. Transient
etc... Neither one of us like Property Group, but it's the one we
disliked the least. :)

> In particular, the
> document.getObjectsByX names are galling given that their function is
> to get groups of statements sharing a common *subject* (not object).

I changed it to getItemsBy...() - I'm sure it'll change again.

> For anyone just starting out with RDF and RDFa, who has just grasped
> the notion of subject, predicate and object, the following method name
> will make their head asplode...
> 	document.getObjectsBySubject

Good point. The API should prevent developer brain-pan asplosions.

> How about renaming them getItemsByX? Or is that too close to
> Microdata's API.

I like the simplicity of Microdata's API - unfortunately, it's a bit too
naive for our use cases. Making names accessible to people that don't
understand RDF, but understand basic programming concepts would be

-- manu

Manu Sporny (skype: msporny, twitter: manusporny)
President/CEO - Digital Bazaar, Inc.
blog: Bitmunk 3.2.2 - Good Relations and Ditching Apache+PHP
Received on Thursday, 20 May 2010 05:00:12 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:19:47 UTC