W3C home > Mailing lists > Public > public-rdfa-wg@w3.org > May 2010

Re: RDFa DOM API (Fully merged)

From: Dan Brickley <danbri@danbri.org>
Date: Wed, 19 May 2010 15:06:52 +0200
Message-ID: <AANLkTilAuchDdhXHxIGDTgf8ZKAEk3aWVkcdaEyFvSN3@mail.gmail.com>
To: Toby Inkster <tai@g5n.co.uk>
Cc: Manu Sporny <msporny@digitalbazaar.com>, RDFa WG <public-rdfa-wg@w3.org>
On Wed, May 19, 2010 at 2:36 PM, Toby Inkster <tai@g5n.co.uk> wrote:
> On Wed, 19 May 2010 00:08:28 -0400
> Manu Sporny <msporny@digitalbazaar.com> wrote:
>> http://www.w3.org/2010/02/rdfa/sources/rdfa-dom-api/
> I really don't like some of the method names. In particular, the
> document.getObjectsByX names are galling given that their function is
> to get groups of statements sharing a common *subject* (not object).
> For anyone just starting out with RDF and RDFa, who has just grasped
> the notion of subject, predicate and object, the following method name
> will make their head asplode...
>        document.getObjectsBySubject

Yes, the subject/predicate/object terminology is sometimes useful, but
in an API I'd suggest steering away from it if possible. Especially
with the 'O' in DOM standing for object, it'll cause confusion.

> How about renaming them getItemsByX? Or is that too close to
> Microdata's API.

Imitation is the sincerest form of flattery. I quite like 'item'...

Received on Wednesday, 19 May 2010 13:14:04 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:19:47 UTC