Re: A Proposal for subject setting by @class

Ben,

I need some clarification, to understand exactly what you propose.

At the moment, if I have in RDFa:

<div about="#me" id="me">
 <div the_attribute_that_shall_not_be_named="cal:Vevent"
   rel="foaf:topic">
   <span property="cal:dtstart">2007-07-07</span>
 </div>
</div>

The generated RDF is, if I am not mistaken:

<#me> rel="foaf:topic" [
 a cal:Vevent;
 cal:dtstart "2007-07-07".
 ].

which seems to cover the calendar event case that you refer to: I have a
calendar event without naming it. However, regardless of the use case
you refer to, I guess what you propose is that

<div about="#me" id="me">
 <div the_attribute_that_shall_not_be_named="cal:Vevent">
   <span property="cal:dtstart">2007-07-07</span>
 </div>
</div>

yields:

[
 a cal:Event;
 cal:dtstart "2007-07-07".
].

Is this correct? I presume the possible usage for this is:

<div about="#me" id="me">
 <div the_attribute_that_shall_not_be_named="cal:Vevent">
   <span property="cal:dtstart">2007-07-07</span>
   <span resource="a:Something" rev="a:something">Bla bla bla</span>
 </div>
</div>

yielding:

<a:Something> a:something
 [
  a cal:Event;
  cal:dtstart "2007-07-07".
 ].
 

Before I say yay or nay, I would like to understand whether this is what
you refer to...

Thanks

Ivan

Ps: I realise I should have used
"@resource_or_href_depending_on_decision" instead of "@resource" in the
last example:-)


Ben Adida wrote:
> 
> We've recently had a discussion about what to do when one wants to
> publish a calendar event on a page without necessarily naming it.
> 
> The recommendation was:
> 
> <div class="cal:Vevent" rel="rdf:li">
> ...
> 
> or rel="foaf:topic"
> 
> (note that I'm using the @class notation though this issue has now been
> reopened, so assume
> 
> the_attribute_that_shall_not_be_named="cal:Vevent"
> 
> where I say @class.)
> 
> I propose that, when a @class appears with a namespaced-value, there be
> an implicit @about set for contained statements, exactly as if there
> were a @rel. I suspect someone else has brought this up before, but I
> can't seem to find it in the archive.
> 
> So, for example:
> 
> <div class="cal:Vevent">
>   <span property="cal:dtstart">2007-07-07</span>
> </div>
> 
> would yield:
> 
> _:div0 rdf:type cal:Vevent ;
>        cal:dtstart "2007-07-07" .
> 
> This is a small but noticeable change, and it may invalidate some
> existing markup (though unlikely, since most use case here involve using
> an @about on the same @div, in which case the @about takes precedence.)
> 
> Thoughts, comments?
> 
> -Ben
> 

-- 

Ivan Herman, W3C Semantic Web Activity Lead
URL: http://www.w3.org/People/Ivan/
PGP Key: http://www.cwi.nl/%7Eivan/AboutMe/pgpkey.html
FOAF: http://www.ivan-herman.net/foaf.rdf

Received on Sunday, 8 July 2007 09:33:37 UTC