W3C home > Mailing lists > Public > public-rdf-dawg@w3.org > July to September 2012

RE: SPARQL Update Editorial issue/ SPARQL Grammar suggestion in the context of Update (LOAD INTO iri vs. LOAD INTO GRAPH iri)

From: Polleres, Axel <axel.polleres@siemens.com>
Date: Thu, 5 Jul 2012 15:18:08 +0200
To: "andy.seaborne@epimorphics.com" <andy.seaborne@epimorphics.com>, "public-rdf-dawg@w3.org" <public-rdf-dawg@w3.org>
Message-ID: <9DA51FFE5E84464082D7A089342DEEE8013E03AB8FBE@ATVIES9917WMSX.ww300.siemens.net>
Thanks Andy,

Fair points... Any other opinions? I wouldn't want to risk another LC for update and, in case we see implementations to allow skipping "GRAPH" later on, a future WG could still standardize that without Backwards compatibility problems, right?

So, I'll just do the editorial fix in
http://www.w3.org/TR/sparql11-update/#mappingRequestsToOperations

Best,
Axel



--
Dr. Axel Polleres
Siemens AG Österreich
Corporate Technology Central Eastern Europe Research & Technologies
CT T CEE

Tel.: +43 (0) 51707-36983
Mobile: +43 (0) 664 88550859
Fax: +43 (0) 51707-56682 mailto:axel.polleres@siemens.com


> -----Original Message-----
> From: Andy Seaborne [mailto:andy.seaborne@epimorphics.com]
> Sent: Thursday, 5 July 2012 3:07 PM
> To: public-rdf-dawg@w3.org
> Subject: Re: SPARQL Update Editorial issue/ SPARQL Grammar
> suggestion in the context of Update (LOAD INTO iri vs. LOAD
> INTO GRAPH iri)
>
> As a change it seems OK but it's rather late in the cycle.
> Can we legitimately reply to comments making suggestions
> saying "sorry - it's late" if we ourselves are fine tuning
> things.  It's not broken.
>
> This would require a new LC for Update, in my opinion,
> because implementations would be changed.
>
> >>   Update:
> >>     mark the GRAPH keyword optional in Section 3.1.4 LOAD,
> >> 3.1.5 CLEAR, 3.2.1 CREATE, 3.2.2 DROP
>
> and it is a material change to the update doc itself (I don't
> think the grammar being in query means that we can use that
> when update-only language syntax is changed).
>
> And inline ...
>
> On 05/07/12 11:01, Polleres, Axel wrote:
> > Sorry, missed something here:
> >
> >> The implied changes would be:
> >>
> >>   Query:
> >>
> >      only the suggested grammar change (since GraphRef is
> only used by Update-relevant
> >      grammar productions and thus doesn't otherwise affect
> the query document, as far as I can see)
> >      [...]
> >
> >
> > Cheers,
> > Axel
> >
> >> -----Original Message-----
> >> From: Polleres, Axel
> >> Sent: Thursday, 5 July 2012 11:52 AM
> >> To: public-rdf-dawg@w3.org
> >> Subject: SPARQL Update Editorial issue/ SPARQL Grammar
> suggestion in
> >> the context of Update (LOAD INTO iri vs. LOAD INTO GRAPH iri)
> >>
> >> A student of mine just pointed me to a small thing which I
> wanted to
> >> ask your opinions on:
> >> For  DROP, CLEAR, CREATE, and LOAD  the GRAPH keyword is
> obligatory,
> >> i.e. you have to write:
> >>    DROP GRAPH iri
> >>    LOAD INTO GRAPH iri
> >> ...
> >> but can't simply write
> >>    DROP iri
> >>    LOAD INTO iri
> >>
> >> The student realized this, since we have some example in
> >> http://www.w3.org/TR/sparql11-update/#mappingRequestsToOperati
> >> ons in Table 1 where we forgot the GRAPH keyword...
>
> Editorial - fix it regardless, - in any case, theyshould use
> the full forms for clarity.
>
> >> Couldn't we make 'GRAPH' optional here, just as 'WHERE' is
> optional
> >> in WhereClause, i.e. change the GraphRef production
> >>
> >> s/
> >>   [46]  GraphRef  ::=  'GRAPH' iri
> >> /
> >>   [46]  GraphRef  ::=  'GRAPH'? iri
> >> /
> >>
> >> This would seem to be a minor, but handy change and still
> possible as
> >> long as we are still before LC publication for the grammar
> along with
> >> the Query document: I think making the GRAPH keyword OPTIONAL here
> >> would still be a minor enough change for Update to call it
> >> "editorial", since it doesn't invalidate anything from the LC
> >> version.
> >>
> >> The implied changes would be:
> >>
> >>   Query:
> >>
> >>   Update:
> >>     mark the GRAPH keyword optional in Section 3.1.4 LOAD,
> >> 3.1.5 CLEAR, 3.2.1 CREATE, 3.2.2 DROP
> >>
> >>
> >> Please note that the GRAPH keyword is already optional in
> ADD, MOVE,
> >> COPY, cf.
> >>
> >>     [45]  GraphOrDefault  ::=  'DEFAULT' | 'GRAPH'? Iri
> >>
> >> So, I think this minor change would make the Update language more
> >> coherent, or would there be any problems with it?
> >>
> >> Best regards,
> >> Axel
> >>
> >> --
> >> Dr. Axel Polleres
> >> Siemens AG Österreich
> >> Corporate Technology Central Eastern Europe Research &
> Technologies
> >> CT T CEE
> >>
> >> Tel.: +43 (0) 51707-36983
> >> Mobile: +43 (0) 664 88550859
> >> Fax: +43 (0) 51707-56682 mailto:axel.polleres@siemens.com
> >>
> >>
> >
>
>
>
Received on Thursday, 5 July 2012 13:18:51 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 16:15:48 GMT