W3C home > Mailing lists > Public > public-qt-comments@w3.org > March 2017

Re: [FO31] array:join – misleading name?

From: Michael Kay <mike@saxonica.com>
Date: Thu, 16 Mar 2017 09:55:00 +0000
Cc: public-qt-comments <public-qt-comments@w3.org>, Andrew Coleman <andrew_coleman@uk.ibm.com>
Message-Id: <7F115E7A-04B1-4320-8E20-CE3EDA254FCA@saxonica.com>
To: Thomas Fischer <fischer.th@gmail.com>
Just for the record: this comment was captured at


where you can find the record of the Working Group's deliberations.

Many thanks for taking the time to comment on the specification.

Michael Kay
for the XSL and XQuery Working Groups

> On 30 Nov 2016, at 16:20, Thomas Fischer <fischer.th@gmail.com> wrote:
> Hi,
> The documentation for array:join says:
>     Concatenates the contents of several arrays
> and "concat" is a common term for such functionality for arrays, whereas "join" is common to join the elements of an array into a string, separated by a specified separator.
> Therefore I would propose:
>   array:join($array as array(*)) as xs:string
>   array:join($array as array(*), $separator as xs:string) as xs:string
>   array:concat($arrays as array(*)*) as array(*)
> salute
> Th. Fischer
Received on Thursday, 16 March 2017 09:55:29 UTC

This archive was generated by hypermail 2.3.1 : Thursday, 16 March 2017 09:55:29 UTC