W3C home > Mailing lists > Public > public-qt-comments@w3.org > October 2015

[Bug 29236] New: [xslt30ts] package-100, 101: extra empty <row> elements in output

From: <bugzilla@jessica.w3.org>
Date: Sat, 24 Oct 2015 13:23:13 +0000
To: public-qt-comments@w3.org
Message-ID: <bug-29236-523@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=29236

            Bug ID: 29236
           Summary: [xslt30ts] package-100, 101: extra empty <row>
                    elements in output
           Product: XPath / XQuery / XSLT
           Version: Last Call drafts
          Hardware: PC
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XSLT 3.0 Test Suite
          Assignee: abel.online@xs4all.nl
          Reporter: mike@saxonica.com
        QA Contact: public-qt-comments@w3.org
  Target Milestone: ---

In package-100 I'm getting two empty <row> elements at the start, as in the
expected results:

In package-101 I'm getting one empty <row> element, which isn't expected.

The first empty row appears to arise because we're applying templates to the
variable $csv:quote-ok, and the value of this variable is not an empty
sequence, but a document node with no children (because the xsl:variable has no
"as" attribute).

I can fix the results for package-101 by adding 'as="xs:error?"' to the
xsl:variable declaration, but when I do this, package-101 only has a single
empty <row/> at the start: which is, I think, the correct result.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
Received on Saturday, 24 October 2015 13:23:17 UTC

This archive was generated by hypermail 2.3.1 : Saturday, 24 October 2015 13:23:18 UTC