W3C home > Mailing lists > Public > public-qt-comments@w3.org > July 2005

[Bug 1640] New: [FS] editorial: 4.7.1.1 Attributes

From: <bugzilla@wiggum.w3.org>
Date: Fri, 15 Jul 2005 21:58:53 +0000
To: public-qt-comments@w3.org
Cc:
Message-Id: <E1DtYCr-0007mH-EV@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=1640

           Summary: [FS] editorial: 4.7.1.1 Attributes
           Product: XPath / XQuery / XSLT
           Version: Last Call drafts
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Formal Semantics
        AssignedTo: simeon@us.ibm.com
        ReportedBy: jmdyck@ibiblio.org
         QAContact: public-qt-comments@w3.org


4.7.1.1 Attributes

"Like literal XML element constructors, literal XML attribute constructors
..."
    s/literal XML/direct/g ?

(grammar)
    It would be nice if the relevant productions were moved from 4.7.1 to
    this section.
        DirAttributeList
        DirAttributeValue
        QuotAttrValueContent
        AposAttrValueContent
        QuotAttrContentChar
        AposAttrContentChar
        EscapeQuot
        EscapeApos

Notation
"for the normalization of the content of direct attribute constructors."
    Delete "the content of". Two of them are only concerned with content,
    but []_Attribute is concerned with larger things.

Norm

"The normalization rules for attributes ignore namespace-declaration
attributes"
    Maybe change "for attributes" to "in this section".

"An AttributeList"
    Change to "A DirAttributeList".

Norm / rule 1 / LHS
    Insert an ellipsis.

    'Attributen' is preceded by two double-quotes. Delete one.

Norm / rule (1|2|3)
AttributeValue
    Use of the Formal symbol AttributeValue is completely inappropriate.
    Change
        '"' AttributeValue '"'
    to
        DirAttributeValue
Norm / rule 3 / RHS
    Change 'AttributeValue' to 'DirAttributeValue'.

Norm / rule 3
    Change [[ Prefix:LocalPart ]]_Expr to just Prefix:LocalPart.
    (see 4.7.1 / Norm / rule (3|4) in Bug 1627)

"attribute-content unit"
    There is no definition for this term.

"because the rule ... are applied"
    s/are/is/

Norm / rule (4|5)
"AttributeValueContent"
    The symbol 'AttributeValueContent' is not defined.  At least change
    it to 'AttributeContentUnit' to be consistent with the prose.

Norm / rule (4|5)
[[]]_AttributeContent-unit
    (Similar comments as for _ElementContent-unit in Bug 1627.)

    This construct only appears on the LHS of mapping rules, so there's
    nothing to invoke it.  Probably the RHS of rule 3 is supposed to
    invoke it rather than [[]]_AttributeContent.

    The subscript-names 'AttributeContent' and 'AttributeContent-unit'
    seem to be assigned each other's semantics. That is, the '-unit'
    subscript should be concerned with normalizing a single unit, and the
    other subscript with normalizing the whole content.

    And 'Unit' would match your naming convention better than '-unit'.

Norm / rule 5 / LHS
"AttributeValueContent1 ..., AttributeValueContentn
    Delete comma.

Norm / rule 5 / RHS
"fs:item-sequence-to-untypedAtomic( ... )"
    This function takes a single argument (of type item*), so there should
    be an extra pair of parentheses around what currently appear to be its
    args.

"by normalizing each individual expression in its expression sequence and
then construct a sequence"
    s/construct/constructing/
Received on Friday, 15 July 2005 21:58:55 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:45:25 UTC