W3C home > Mailing lists > Public > public-qt-comments@w3.org > January 2005

RE: [F&O] fn:local-name-from-QName should be renamed local-part-from-QName

From: Ashok Malhotra <ashok.malhotra@oracle.com>
Date: Wed, 19 Jan 2005 18:50:49 -0800
To: Per Bothner <per@bothner.com>, public-qt-comments@w3.org
Message-ID: <20050119185049765.00000000792@amalhotr-pc>

Per:
Thank you for your comment.  The joint WGs considered this at the January 19 meeting
and decided that the name of the function was chosen consciously and that no change
was necessary.

All the best, Ashok
 

> -----Original Message-----
> From: public-qt-comments-request@w3.org 
> [mailto:public-qt-comments-request@w3.org] On Behalf Of Per Bothner
> Sent: Wednesday, December 22, 2004 6:43 PM
> To: public-qt-comments@w3.org
> Subject: [F&O] fn:local-name-from-QName should be renamed 
> local-part-from-QName
> 
> 
> I noticed some incompatibility between the name "local-name"
> and the JAXP (Java) method names getLocalPart vs getLocalName.
> 
> The F&O method local-name-from-QName corresponds to the JAXP 
> methods QName.getLocalPart.
> 
> I think the phrase "local-part" is more precise, since it 
> doesn't make sense to get the "local name" of a name - you 
> get the local *part* of a name.  Plus of course it's nice to 
> have consistency between the XQuery API and the Java API.
> 
> The fn:local-name corresponds to the DOM method getLocalName.
> That makes sense: the local name of a node is the local part 
> of the QName of a node.
> -- 
> 	--Per Bothner
> per@bothner.com   http://per.bothner.com/
> 
> 
> 
> 
Received on Thursday, 20 January 2005 02:51:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 27 March 2012 18:14:37 GMT