W3C home > Mailing lists > Public > public-qt-comments@w3.org > December 2003

RE: [F&O] 15.1.8 fn:exists

From: Dimitre Novatchev <dnovatchev@yahoo.com>
Date: Fri, 5 Dec 2003 11:41:00 -0800 (PST)
Message-ID: <20031205194100.84736.qmail@web41106.mail.yahoo.com>
To: "Kay, Michael" <Michael.Kay@softwareag.com>, Ashok Malhotra <ashokma@microsoft.com>, public-qt-comments@w3.org

> I don't think that naming decisions can be made by any democratic
> process; on the contrary, it's probably true that the more people you 
> involve, the harder it is to achieve stylistic consistency. The names 
> will never please everyone. Neither of the names "exists" or "empty" is 
> perfect, because they both have other possible meanings (empty, in 
> particular, is tricky because people might think that empty($E) tests 
> whether $E is an element with no children). We felt in this case that
> brevity is more important than trying to capture the entire semantics of

> the function in its name. We didn't feel that the names you suggested 
> were significantly more likely to be intuitive to users than the 
> existing names.

I am not insisting on changing the names, but was interested to understand
the logic behind these names.

I also thought that the fact that the following expression is an identity
(the constant true()):

  not(empty($seq)) = exists($seq)

would be easier to understand with these names:

 not(empty($seq)) = non-empty($seq)

and the user would have to remember one name less.


Thanks to your clarification I understand that brevity was preferred over
logic in this case.


Thank you,

Dimitre Novatchev.




__________________________________
Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/
Received on Friday, 5 December 2003 14:41:02 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 27 March 2012 18:14:28 GMT