W3C home > Mailing lists > Public > public-qa-dev@w3.org > November 2012

Re: Slow validations on some doctypes

From: Jaime Iniesta <jaimeiniesta@gmail.com>
Date: Sat, 3 Nov 2012 13:15:55 +0100
Message-ID: <CAKFFWV-TEd81NayDhD07+Bk4N5YpF4g5sRhPjfAy9v36_7XO0g@mail.gmail.com>
To: Etienne Miret <etienne.miret@ens-lyon.org>
Cc: public-qa-dev@w3.org
Hi Etienne

2012/11/3 Etienne Miret <etienne.miret@ens-lyon.org>

> Hi James
>
> Thanks Jirka, this seems to be the issue -- the URL for the specified
> DOCTYPE on that page does not exist, so there is a timeout after 40 seconds
> trying to fetch it. If I remove the DOCTYPE line (or make it just <!DOCTYPE
> html>), it goes fast.
>
> Now, why doesn't this happen when I validate it on http://validator.w3.org ,
> but does happen on my local install?
>
>
> The validator at w3.org has a list of known doctypes that it will fetch
> from its local hard drive. I guess the doctype you are using belongs to
> this list. Did you installed this DTD library? (<
> http://validator.w3.org/docs/install.html#install-download>)
>
>
>
Yes I did download the DTD library from there and put it inside
/usr/local/validator/htdocs -- But it seems that this library does not
include the "xhtml-rdfa-2" doctype. So I guess that's why it's looking for
it outside?

If you want to reproduce this, I followed this step-by-step guide:

https://github.com/tlvince/w3c-validator-guide

Thanks!
Received on Saturday, 3 November 2012 12:16:22 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Saturday, 3 November 2012 12:16:24 GMT