W3C home > Mailing lists > Public > public-qa-dev@w3.org > June 2010

Re: Validator timeout and XML-LibXML bug

From: Ville Skyttä <ville.skytta@iki.fi>
Date: Mon, 14 Jun 2010 09:34:39 +0300
To: ted@w3.org
Cc: public-qa-dev@w3.org, "Dominique Hazael-Massieux" <dom@w3.org>, jean-gui@w3.org, tgambet@w3.org
Message-Id: <201006140934.40264.ville.skytta@iki.fi>
On Monday 14 June 2010, Ted Guild wrote:
> On Mon, 2010-06-14 at 01:00 +0300, Ville Skyttä wrote:
> > So as far as I'm concerned, CVS is again in a state that a real
> > validator
> > release (1.0 finally?) instead of patch backporting would be a good
> > alternative.  I'll go and update whatsnew.html after sending this
> > mail.
> 
> +1 to finally dubbing it a 1.0 after so many years, then again what's
> the point of a version number?

I've changed version numbers to 1.0 in CVS and tagged it as validator-1_0-
release.

> I'll make time on Monday, tomorrow for getting this into production.
> 
> As Dom said: Ville you rock :)

Thanks, but please note that this fix is not a silver bullet: it just works 
around one (common, I hope) instance of the problem; XML::LibXML's slowness 
when it has lots of errors to report hasn't gone anywhere.  And I think the 
only things that could be done about that is get XML::LibXML fixed, disable 
XML wellformedness checks in the validator, or switch to another XML parser.
Received on Monday, 14 June 2010 06:35:10 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 August 2010 18:12:51 GMT