W3C home > Mailing lists > Public > public-qa-dev@w3.org > December 2008

Re: latest LWP running under perl -T dies for some values of agent()

From: olivier Thereaux <ot@w3.org>
Date: Tue, 16 Dec 2008 11:22:06 -0500
Cc: public-qa-dev@w3.org
Message-Id: <0449206E-A079-430F-B589-776161B280BE@w3.org>
To: Ville Skyttä <ville.skytta@iki.fi>

Hello,

On 10-Oct-08, at 12:47 PM, Ville Skyttä wrote:
> On Tuesday 26 August 2008, Ville Skyttä wrote:
>> On Tuesday 26 August 2008, olivier Thereaux wrote:
>>> LWP dies with:
>>>   Software error: Insecure dependency in eval while running with -T
>>> switch at /usr/local/share/perl/5.10.0/HTTP/Message.pm line 413.
>>
>> I dug into this a bit and reported it upstream along with a quick  
>> and dirty
>> patch that gets things going again:
>> http://rt.cpan.org/Public/Bug/Display.html?id=38736
>
> This is fixed in upstream git, but no release including it is out  
> yet AFAIK:
> http://gitorious.org/projects/libwww-perl/repos/mainline/commits/01f0ce40d8b4ea6c887bedc2cd4afc56e038491e

Kudos to you (and Gisle), this is now working fine on qa-dev with the  
LWP v5.822, which I installed by hand today (the one provided with  
debian unstable is 5.820, still broken).

-- 
olivier
Received on Tuesday, 16 December 2008 16:22:15 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 August 2010 18:12:49 GMT