W3C home > Mailing lists > Public > public-qa-dev@w3.org > September 2004

Re: [wmvs] Prerequisites, Minimum Versions, Platforms?

From: Terje Bless <link@pobox.com>
Date: Sun, 12 Sep 2004 13:09:32 +0200
To: QA Dev <public-qa-dev@w3.org>
Message-ID: <r02010300-1035-39CB312604AC11D98FFD0030657B83E8@[193.157.66.23]>

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bjoern Hoehrmann <derhoermi@gmx.net> wrote:

>* Ville Skyttä wrote:
>>BTW, does anybody know whether the Perl requirement is actually 5.8.0+
>>or let's say 5.8.4+?  I've heard some bad things about early 5.8.x
>>Perls and Unicode.
>
>I am running Perl 5.8.2 which does not have problems with either the
>current code or future dependencies like SGML::Parser::OpenSP. I am not
>sure about 5.8.0 but 5.8.1 should do just fine.

The main concern is probably the quality and completeness of the UNICODE
support in Perl. As Ville says “I've heard some bad things” about the early
5.8 versions' UNICODE support in this sense, but I don't recall seeing the
specifics.

Unless we have any specific information about this, we might want to require
>= 5.8.0 instead of shooting for some arbitrary minor revision in there.


We might also consider that issue similar to the iconv() supported charsets;
so long as the facility itself is present and functioning, coverage and
correctness bugs are an issue for the underlying system and not something we
need to deal with in our dependencies.


I dunno. Opinions? yesno on >= 5.8.0? .1 .2 .3?


- -- 
"Hath no man's dagger here a point for me?"   - Leonato, Governor of Messina.
                   See Project Gutenberg <URL:http://promo.net/pg/> for more.

-----BEGIN PGP SIGNATURE-----
Version: PGP SDK 3.0.3

iQA/AwUBQUQuaqPyPrIkdfXsEQJ82wCeKWaf5EVdKFPEX6QbwgpHFMtQSdwAn2gr
abA+UJT3Ma9uS+AE1dQOVp8+
=2oXD
-----END PGP SIGNATURE-----
Received on Sunday, 12 September 2004 11:09:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 August 2010 18:12:44 GMT