W3C home > Mailing lists > Public > public-qa-dev@w3.org > September 2004

Re: [wmvs] Prerequisites, Minimum Versions, Platforms?

From: (wrong string) ä <ville.skytta@iki.fi>
Date: Wed, 08 Sep 2004 01:53:52 +0300
To: QA Dev <public-qa-dev@w3.org>
Message-Id: <1094597632.17961.227.camel@bobcat.mine.nu>

On Mon, 2004-09-06 at 14:02, Terje Bless wrote:

> And IMO, targetting mod_perl implies targetting Apache, so if we've discounted
> that then this issue is also moot. Ville has done some excellent work in
> making check support running under mod_perl  I've borked it at some point
> during 0.6.7->HEAD, but :-)

Actually, I believe it has for some mysterious reason stopped working
somewhere between 0.6.6 and 0.6.7 (or in 0_6_0-branch anyway when I last
took a look), so it's possible that you did not have anything directly
to do with the borkage :)

I do enjoy developing with mod_perl because it is a pretty demanding
environment and problems due to sloppiness or bad programming practices
often emerge loud and clear right away (and I have a feeling that most
of these are real problems which could bite with "normal" CGIs as
well).  IPC is one thing that is a real PITA with it though, that should
go away with the introduction of S::P::O.

Supporting mod_perl, sure if it can be done in a non-intrusive way, but
making it a dependency... hmph.  I'm not sure if that would be a good
idea.  IMHO, the most important points in platform etc requisites are:
what is the runtime environment for the production service at v.w.o as
well as what do the active developers/testers have conveniently
available and are comfortable working with.

Regarding minimum versions in the "conveniently available" context, I
would not personally prefer gratuitous bleeding edge requirements; I've
been successfully using strictly only rpm packaged software for years
except for the projects I'm actively working on.  Well, consequently,
I've been packaging quite a lot of software myself though :) but that
does not imply "convenient", I would be happy to find the needed stuff
already packaged somewhere.

> Everything points to Perl 5.8 for WMVS 0.8  as the fixes that require 5.8
> probably won't happen for 0.7  but I want to make sure I really understand
> the impact of making that change. I can live with losing the Eunices and
> ancient Debian (iff they don't ship 5.8), but if it were to, say, nuke SUSE,
> Mandrake, and Gentoo I'd be a little more worried.

Perl 5.8.0 was released over two years ago.  Surely that's no problem
for relatively recent versions any of the above mentioned distros.

BTW, does anybody know whether the Perl requirement is actually 5.8.0+
or let's say 5.8.4+?  I've heard some bad things about early 5.8.x Perls
and Unicode.
Received on Tuesday, 7 September 2004 22:53:54 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 August 2010 18:12:44 GMT