W3C home > Mailing lists > Public > public-prov-wg@w3.org > September 2012

Re: PROV-ISSUE-557: why collectionMemberOf instead of hadMember? [XML Serialization]

From: Luc Moreau <l.moreau@ecs.soton.ac.uk>
Date: Fri, 28 Sep 2012 10:10:41 +0100
Message-ID: <EMEW3|bfe44043cd8965764aea721a27cd5318o8RAAf08l.moreau|ecs.soton.ac.uk|50656991.1080803@ecs.soton.ac.uk>
To: Stephan Zednik <zednis@rpi.edu>
CC: Provenance Working Group <public-prov-wg@w3.org>

Hi Stephan
HadMember in prov-dm does not have a complete flag, nor an Id.
http://www.w3.org/TR/prov-dm/#dfn-hadmember

Should this become:

   <xs:complexType name="Membership">
     <xs:sequence>
       <xs:element name="collection" type="prov:EntityRef"/>
       <xs:element name="entity"          type="prov:EntityRef" 
maxOccurs="unbounded"/>
     </xs:sequence>
   </xs:complexType>


Also, do we allow multiple entities?

Finally, should this be HadMember rather than Membership like the other 
relations?

Luc

On 09/27/2012 04:39 PM, Stephan Zednik wrote:
> I have updated the xml schema to align with PROV-DM terminology and updated xml serialization examples accordingly.
>
> https://dvcs.w3.org/hg/prov/rev/cb1e74b9ec29
>
> and will now change the ISSUE status to PENDING REVIEW.
>
> --Stephan
>
> On Sep 27, 2012, at 9:27 AM, Stephan Zednik <zednis@rpi.edu> wrote:
>
>> Correction, I will rename collectionMemberOf to hadMember.
>>
>> --Stephan
>>
>> On Sep 27, 2012, at 9:23 AM, Stephan Zednik <zednis@rpi.edu> wrote:
>>
>>> I believe Luc is correct, this is a legacy name from when we had both dictionaryMemberOf and collectionMemberOf.
>>>
>>> I will make the change to memberOf.
>>>
>>> --Stephan
>>>
>>> On Sep 18, 2012, at 8:49 AM, Luc Moreau <L.Moreau@ecs.soton.ac.uk> wrote:
>>>
>>>> Hi,
>>>>
>>>> This relation is still legacy definition dating back from the time we had dictionary/collection.
>>>>
>>>> Professor Luc Moreau
>>>> Electronics and Computer Science
>>>> University of Southampton
>>>> Southampton SO17 1BJ
>>>> United Kingdom
>>>>
>>>> On 18 Sep 2012, at 15:19, "Provenance Working Group Issue Tracker" <sysbot+tracker@w3.org> wrote:
>>>>
>>>>> PROV-ISSUE-557: why collectionMemberOf instead of hadMember? [XML Serialization]
>>>>>
>>>>> http://www.w3.org/2011/prov/track/issues/557
>>>>>
>>>>> Raised by: Curt Tilmes
>>>>> On product: XML Serialization
>>>>>
>>>>> I realize collectionMemberOf has extra capabilities over a straight hadMember translation (you can specify the 'complete' flag, and specify multiple members in one go), but could we not keep the "hadMember" name for that element even so?
>>>>>
>>>>> All the other XML schema fields have kept the same name for the PROV-N and PROV-XML concepts, it just seems a shame to replace hadMember with collectionMemberOf.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>
>>>
>>>
>>
>>

-- 
Professor Luc Moreau
Electronics and Computer Science   tel:   +44 23 8059 4487
University of Southampton          fax:   +44 23 8059 2865
Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
Received on Friday, 28 September 2012 09:11:09 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 28 September 2012 09:11:09 GMT