W3C home > Mailing lists > Public > public-prov-wg@w3.org > September 2012

Re: PROV-ISSUE-557: why collectionMemberOf instead of hadMember? [XML Serialization]

From: Stephan Zednik <zednis@rpi.edu>
Date: Thu, 27 Sep 2012 09:39:40 -0600
Cc: Provenance Working Group <public-prov-wg@w3.org>
Message-Id: <DD3F9FBB-09B7-4C06-A711-6AF5FE56A325@rpi.edu>
To: Luc Moreau <L.Moreau@ecs.soton.ac.uk>
I have updated the xml schema to align with PROV-DM terminology and updated xml serialization examples accordingly.

https://dvcs.w3.org/hg/prov/rev/cb1e74b9ec29

and will now change the ISSUE status to PENDING REVIEW.

--Stephan

On Sep 27, 2012, at 9:27 AM, Stephan Zednik <zednis@rpi.edu> wrote:

> Correction, I will rename collectionMemberOf to hadMember.
> 
> --Stephan
> 
> On Sep 27, 2012, at 9:23 AM, Stephan Zednik <zednis@rpi.edu> wrote:
> 
>> I believe Luc is correct, this is a legacy name from when we had both dictionaryMemberOf and collectionMemberOf.
>> 
>> I will make the change to memberOf.
>> 
>> --Stephan
>> 
>> On Sep 18, 2012, at 8:49 AM, Luc Moreau <L.Moreau@ecs.soton.ac.uk> wrote:
>> 
>>> Hi,
>>> 
>>> This relation is still legacy definition dating back from the time we had dictionary/collection.
>>> 
>>> Professor Luc Moreau
>>> Electronics and Computer Science
>>> University of Southampton 
>>> Southampton SO17 1BJ
>>> United Kingdom
>>> 
>>> On 18 Sep 2012, at 15:19, "Provenance Working Group Issue Tracker" <sysbot+tracker@w3.org> wrote:
>>> 
>>>> PROV-ISSUE-557: why collectionMemberOf instead of hadMember? [XML Serialization]
>>>> 
>>>> http://www.w3.org/2011/prov/track/issues/557
>>>> 
>>>> Raised by: Curt Tilmes
>>>> On product: XML Serialization
>>>> 
>>>> I realize collectionMemberOf has extra capabilities over a straight hadMember translation (you can specify the 'complete' flag, and specify multiple members in one go), but could we not keep the "hadMember" name for that element even so?
>>>> 
>>>> All the other XML schema fields have kept the same name for the PROV-N and PROV-XML concepts, it just seems a shame to replace hadMember with collectionMemberOf.
>>>> 
>>>> 
>>>> 
>>>> 
>>> 
>>> 
>> 
>> 
>> 
> 
> 
> 
Received on Thursday, 27 September 2012 15:40:10 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 27 September 2012 15:40:11 GMT