W3C home > Mailing lists > Public > public-prov-wg@w3.org > September 2012

Re: PROV-ISSUE-477 (rename toplevel-bundle): rename toplevel-bundle to dataset [prov-n]

From: Luc Moreau <l.moreau@ecs.soton.ac.uk>
Date: Mon, 03 Sep 2012 14:17:22 +0100
Message-ID: <EMEW3|f50b24b58722a215a7295315b309c54do82EHS08l.moreau|ecs.soton.ac.uk|5044ADE2.4030108@ecs.soton.ac.uk>
To: public-prov-wg@w3.org
Hi,

I think that we should align the terminology of prov-n to the one 
adopted in prov-constraints,
and rename prov-n 'toplevel bundle' to 'prov document'.

For the avoidance of doubt, this is not a change of design, it's 
terminology alignment.

Luc

On 10/08/12 16:40, James Cheney wrote:
> I believe this issue can be handled independently of ISSUE-474.  If the editors of PROV-N wish to change the term "toplevel bundle" and keywords "bundle" and "endBundle" to something else that matches this terminology, that would be fine with me, but I don't insist on it.
>
> My suggestion would be something like:
>
> "toplevel bundle" -> "PROV document"
> opening "bundle" --> "provenance" or just "prov"
> closing "endBundle" --> "endProvenance" or just "endProv"
>
> but again, if people like it the way it is I'm happy with closing.
>
> If we keep the existing terminology, we should probably change PROV-CONSTRAINTS to make clear that what it calls "PROV document" is the same as what PROV-N calls "toplevel bundle" (and perhaps suggest that we hope/expect it will align with "RDF dataset", but make this a non-normative remark.  Or would that be too much of a red flag?)
>
> --James
>
>
> On Aug 10, 2012, at 12:23 PM, Ivan Herman wrote:
>
>> Oops. For some reasons this was answered on Issue-474. For the sake of completeness and issue management, let me repeat my answer:
>>
>> That would lead to a possible confusion. The term 'dataset' is used in the SW world, namely in SPARQL. It *may* be the term adopted by RDF 1.1 for a collection of named graphs and, actually, it *may* be the right abstraction for Prov, too, but... we are not yet sure. And if we end up using the same term but with a different meaning then, well, hell is loose:-)
>>
>> B.t.w., if I use the RDF datasets as an analogy: that consists of (G, (n1,G1),....,(ni,Gi)), where (ni,Gi) is, to use the current terminology, a named graph (that is the term used in SPARQL) and G is the 'default graph'. As an analogy, what about 'default bundle' ?
>>
>> Ivan
>>
>>
>>
>>
>> On Aug 10, 2012, at 09:57 , Provenance Working Group Issue Tracker wrote:
>>
>>> PROV-ISSUE-477 (rename toplevel-bundle): rename toplevel-bundle to dataset [prov-n]
>>>
>>> http://www.w3.org/2011/prov/track/issues/477
>>>
>>> Raised by: Luc Moreau
>>> On product: prov-n
>>>
>>>
>>> Following discussion on ISSUE-474, let us rename toplevel-bundle to dataset.
>>>
>>> Hence, what was written
>>>
>>> bundle
>>> prefix ex <http://ex.com>
>>> entity(ex:a)
>>> //...
>>> endBundle
>>>
>>> would become
>>>
>>>
>>> dataset
>>> prefix ex <http://ex.com>
>>> entity(ex:a)
>>> //...
>>> endDataset
>>>
>>>
>>>
>>
>> ----
>> Ivan Herman, W3C Semantic Web Activity Lead
>> Home: http://www.w3.org/People/Ivan/
>> mobile: +31-641044153
>> FOAF: http://www.ivan-herman.net/foaf.rdf
>>
>>
>>
>>
>>
>>
>>
>

-- 
Professor Luc Moreau
Electronics and Computer Science   tel:   +44 23 8059 4487
University of Southampton          fax:   +44 23 8059 2865
Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
Received on Monday, 3 September 2012 13:18:02 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 3 September 2012 13:18:02 GMT