W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

From: Daniel Garijo <dgarijo@delicias.dia.fi.upm.es>
Date: Mon, 14 May 2012 23:09:24 +0200
Message-ID: <CAExK0Df=nSTd-MnrA4T2Vrig2UtLe9keCxyfxzuraTeTjkTcqQ@mail.gmail.com>
To: Luc Moreau <L.Moreau@ecs.soton.ac.uk>
Cc: Timothy Lebo <lebot@rpi.edu>, Jun Zhao <jun.zhao@zoo.ox.ac.uk>, "public-prov-wg@w3.org" <public-prov-wg@w3.org>
Hi Luc,
the problem I have with the current name is that I find confusing what is
quoting what
in the relationship. It may have to do with the fact that I am used to see
that something was quoted in some other
source, while this is very unlikely to happen with derivation (a was
derived in b?). Thus wasQuotedFrom
sounds strange, while wasDerivedFrom doesn't.

However, I have to recognize that my suggestions haven't had enough
support. The only ones Tim hasn't given a
-1 are clear about the directionality, but do not convince me completely
(it would be very weird to see a property
in the present tense when all the rest are in past tense, and I can't
remember if "wasQuoteOf" has other problems
besides what Tim highlighted). So, if I am the only one  having trouble
with "wasQuotedFrom" then I'll guess I'll have
to live with it and close the issue.

I was wondering if we could leave it open until next telecon, so as to get
feedback from the rest of the group.

Best,
Daniel

2012/5/14 Luc Moreau <L.Moreau@ecs.soton.ac.uk>

>  Hi Daniel,
> Can you remind us what the problem is with the current name and how the
> proposed name addresses it?
> Thanks
>
>
> Professor Luc Moreau
> Electronics and Computer Science
> University of Southampton
> Southampton SO17 1BJ
> United Kingdom
>
> On 14 May 2012, at 19:08, "Daniel Garijo" <dgarijo@delicias.dia.fi.upm.es>
> wrote:
>
>   Hi all,
> It seemed like there was not enough consensus in the telecon past thursday
> about the last proposal.
> If I remember correctly, Tim and Jun voted -1 for prov:wasAQuoteFrom.
>
> So far, there have been the next proposals:
>
>    - quoted: there was no consensus because it could imply an agent
>    instead of an entity.
>    - wasQuoteOf: we started with this definition, and moved away because
>    it was confusing.
>    - hadQuoteFrom: there was no consensus because it could imply that the
>    quotation is partial.
>    - wasAQuoteFrom: there was no consensus because "if it was a quote,
>    then what is it now"?
>    - isAQuoteFrom/isQuoteFrom: there has been no votes on this one, but
>    it goes against having everything
>    in past tense.
>    - wasQuotedFrom: the current name and the only one I have concerns
>    about, because
>    the directionality of the property is not clear enough.
>
> Just a small remark: the issue is about the name of the property. The
> definition on DM is very clear.
>
> During today's prov-o telecon Tim said that he proposed to move away from
> wasQuoteOf in order
> to have something similar to wasDerivedFrom. I would be happy to go back
> to wasQuoteOf if there
> is no other suggestion.
>
> Thoughts, Jun, Tim?
>
> Thanks,
> Daniel
>  2012/5/8 Luc Moreau <L.Moreau@ecs.soton.ac.uk>
>
>> **
>> good idea, we'll put it on Thursday's agenda
>>
>>
>> On 05/08/2012 03:20 PM, Daniel Garijo wrote:
>>
>> Hi Luc,
>> I still think that the name could be improved because the current one is
>> confusing.
>>
>> My last proposal ("wasAQuoteFrom") got a +1 from Stian and Paul
>> (although he said he would think of a better name). Nobody else said
>> anything,
>> so maybe we should ask the rest of the group on thursday?
>>
>> Best,
>> Daniel
>>
>> 2012/5/8 Luc Moreau <L.Moreau@ecs.soton.ac.uk>
>>
>>> Hi Daniel,
>>>
>>> I don't believe there was consensus to change the name of the relation
>>> as you suggested.
>>> We also have removed agents from this definition. Definition of
>>> quote/original attributes
>>> are as follows:
>>>
>>>
>>>
>>> quote: an identifier (e2) for the entity that represents the quote (the
>>> partial copy);
>>> original: an identifier (e1) for the original entity being quoted;
>>>
>>>  Can we close this issue?
>>> Cheers,
>>> Luc
>>>
>>>
>>> On 04/19/2012 11:28 AM, Provenance Working Group Issue Tracker wrote:
>>>
>>>> PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom
>>>> [prov-dm]
>>>>
>>>> http://www.w3.org/2011/prov/track/issues/352
>>>>
>>>> Raised by: Daniel Garijo
>>>> On product: prov-dm
>>>>
>>>> Currently, the DM says:
>>>> A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,attrs) in
>>>> PROV-ASN, contains:
>>>>     quote: an identifier e2, identifying an entity record that
>>>> represents the quote;
>>>>     quoted: an identifier e1, identifying an entity record representing
>>>> what is being quoted;
>>>> ...
>>>>
>>>> However, if we say that e2 wasQuotedFrom e1 it may look like entity e1
>>>> is the one quoting e2 (since we are saying that e2 was quoted).
>>>>
>>>> I think it would be more clear if we rename the property with e2
>>>> wasQuoteOf e1, or e2 hadQuoteFrom e1.
>>>>
>>>> Thoughts?
>>>> Thanks,
>>>> Daniel
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>   --
>>> Professor Luc Moreau
>>> Electronics and Computer Science   tel:   +44 23 8059 4487
>>> University of Southampton          fax:   +44 23 8059 2865
>>> Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
>>> United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
>>>
>>>
>>>
>>
>> --
>> Professor Luc Moreau
>> Electronics and Computer Science   tel:   +44 23 8059 4487
>> University of Southampton          fax:   +44 23 8059 2865
>> Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
>> United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
>>
>>
>
Received on Monday, 14 May 2012 21:09:58 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 14 May 2012 21:10:01 GMT