W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

From: Luc Moreau <L.Moreau@ecs.soton.ac.uk>
Date: Tue, 08 May 2012 15:23:52 +0100
Message-ID: <EMEW3|119a6211e8cda6b48ed67525b39da71eo47FNy08L.Moreau|ecs.soton.ac.uk|4FA92C78.8030708@ecs.soton.ac.uk>
To: Daniel Garijo <dgarijo@delicias.dia.fi.upm.es>
CC: public-prov-wg@w3.org
good idea, we'll put it on Thursday's agenda

On 05/08/2012 03:20 PM, Daniel Garijo wrote:
> Hi Luc,
> I still think that the name could be improved because the current one 
> is confusing.
>
> My last proposal ("wasAQuoteFrom") got a +1 from Stian and Paul
> (although he said he would think of a better name). Nobody else said 
> anything,
> so maybe we should ask the rest of the group on thursday?
>
> Best,
> Daniel
>
> 2012/5/8 Luc Moreau <L.Moreau@ecs.soton.ac.uk 
> <mailto:L.Moreau@ecs.soton.ac.uk>>
>
>     Hi Daniel,
>
>     I don't believe there was consensus to change the name of the
>     relation as you suggested.
>     We also have removed agents from this definition. Definition of
>     quote/original attributes
>     are as follows:
>
>
>
>     quote: an identifier (e2) for the entity that represents the quote
>     (the partial copy);
>     original: an identifier (e1) for the original entity being quoted;
>
>     Can we close this issue?
>     Cheers,
>     Luc
>
>
>     On 04/19/2012 11:28 AM, Provenance Working Group Issue Tracker wrote:
>
>         PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for
>         wasQuotedFrom [prov-dm]
>
>         http://www.w3.org/2011/prov/track/issues/352
>
>         Raised by: Daniel Garijo
>         On product: prov-dm
>
>         Currently, the DM says:
>         A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,attrs)
>         in PROV-ASN, contains:
>             quote: an identifier e2, identifying an entity record that
>         represents the quote;
>             quoted: an identifier e1, identifying an entity record
>         representing what is being quoted;
>         ...
>
>         However, if we say that e2 wasQuotedFrom e1 it may look like
>         entity e1 is the one quoting e2 (since we are saying that e2
>         was quoted).
>
>         I think it would be more clear if we rename the property with
>         e2 wasQuoteOf e1, or e2 hadQuoteFrom e1.
>
>         Thoughts?
>         Thanks,
>         Daniel
>
>
>
>
>
>     -- 
>     Professor Luc Moreau
>     Electronics and Computer Science   tel: +44 23 8059 4487
>     <tel:%2B44%2023%208059%204487>
>     University of Southampton          fax: +44 23 8059 2865
>     <tel:%2B44%2023%208059%202865>
>     Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
>     <mailto:l.moreau@ecs.soton.ac.uk>
>     United Kingdom http://www.ecs.soton.ac.uk/~lavm
>     <http://www.ecs.soton.ac.uk/%7Elavm>
>
>
>

-- 
Professor Luc Moreau
Electronics and Computer Science   tel:   +44 23 8059 4487
University of Southampton          fax:   +44 23 8059 2865
Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
Received on Tuesday, 8 May 2012 14:26:34 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 May 2012 14:26:35 GMT