W3C home > Mailing lists > Public > public-prov-wg@w3.org > February 2012

Re: Tim's approach on Involvement

From: Khalid Belhajjame <Khalid.Belhajjame@cs.man.ac.uk>
Date: Tue, 21 Feb 2012 10:07:05 +0000
Message-ID: <4F436CC9.8000004@cs.man.ac.uk>
To: Timothy Lebo <lebot@rpi.edu>
CC: "public-prov-wg@w3.org Group" <public-prov-wg@w3.org>

Tim,

Thanks for this. I notice that we are using Activity (resp. Entity) as a 
name of a class and activity (resp. entity) as a name for object 
property. In order to be consistent with the terms we are using for 
property names, I would suggest to use hadActivity (or involvedActivity) 
and hasEntity (or involvedEntity) as property names instead.

Thanks, khalid

On 21/02/2012 06:19, Timothy Lebo wrote:
> PROV-O team,
>
> I have updated the owl file. Below is a description of what I generated.
>
> <http://dvcs.w3.org/hg/prov/file/0523d130a6d7/ontology/ProvenanceOntology.owl>
>     prov:specializationOf<http://dvcs.w3.org/hg/prov/file/tip/ontology/ProvenanceOntology.owl>;
>     prov:alternateOf<http://dvcs.w3.org/hg/prov/raw-file/0523d130a6d7/ontology/ProvenanceOntology.owl>;
>     prov:wasRevisionOf<http://dvcs.w3.org/hg/prov/file/4ee3021a9412/ontology/ProvenanceOntology.owl>;
>     prov:qualified [
>         a prov:Revision;
>         prov:entity<http://dvcs.w3.org/hg/prov/file/4ee3021a9412/ontology/ProvenanceOntology.owl>;
>         :diff<http://dvcs.w3.org/hg/prov/rev/0523d130a6d7>;
>    ]
> .
>
> <http://dvcs.w3.org/hg/prov/raw-file/0523d130a6d7/ontology/ProvenanceOntology.owl>
>     prov:specializationOf<http://dvcs.w3.org/hg/prov/raw-file/tip/ontology/ProvenanceOntology.owl>
> .
>
> It sounded like the PROV-O team was to review before releasing to the owl file reviewers, which are to review by Thursday.
>
>
> Regards,
> Tim
>
>
>
> On Feb 20, 2012, at 11:58 PM, Timothy Lebo wrote:
>
>> Stian,
>>
>> Thanks. I reflected your notes into my revision of the ontology.
>> I'm adopting your naming of the new properties (activity, entity, qualified)
>> Based on your lead, I deleted the subprops of qualified, which trims the ontology up nicely, but I'm wondering how one figures out the pattern.
>>
>> new .owl out soon...
>>
>> -Tim
>>
>> On Feb 20, 2012, at 1:39 PM, Stian Soiland-Reyes wrote:
>>
>>> During the last bit of the call I did the modifications in the OWL
>>> file in Protege to do what I understood was Tim's approach:
>>>
>>> http://titanpad.com/LbHy9n4Fb4
>>>
>>>
>>> New classes: Timed, Involvement, AgentInvolvement,
>>> ActivityInvolvement, EntityInvolvement
>>>
>>> New properties: activity, entity, qualified
>>>
>>> Renamed hadTemporalValue ->  time
>>>
>>> Deleted: hadQualifiedInvolvent and 'sub'-props. (but not hadQuoted/quoter yet)
>>>
>>>
>>> -- 
>>> Stian Soiland-Reyes, myGrid team
>>> School of Computer Science
>>> The University of Manchester
>>>
>>
>>
>
>
Received on Tuesday, 21 February 2012 10:07:34 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 April 2012 13:06:56 GMT