W3C home > Mailing lists > Public > public-prov-wg@w3.org > February 2012

Re: prov-wg: Another name for Qualified?

From: Paul Groth <p.t.groth@vu.nl>
Date: Fri, 17 Feb 2012 17:20:27 +0100
Message-ID: <4F3E7E4B.3090707@vu.nl>
To: Jim McCusker <mccusker@gmail.com>
CC: Timothy Lebo <lebot@rpi.edu>, "public-prov-wg@w3.org" <public-prov-wg@w3.org>
Hi Tim, Jim,

I like the suggestion a lot. [English teacher verification is good :-) ] 
Indeed, I was thinking that all the "had" in the ontology were a bit 
verbose. A blank node may indeed be the best way solve it for having 
long types.

A couple of questions in your examples:

- You have the prov:generated relationship but I don't see that in the 
ontology file although I do see it in the ProvRDF page? This is issue 
#98, which has no resolution http://www.w3.org/2011/prov/track/issues/98

- You use the relation prov:entity and not prov:hadQualifiedEntity. This 
also isn't in the ontology or this a suggestion?

---
I'm trying to think of other shorter names that convey the same meaning 
as qualified involvement. Just for less typing but clearly I don't want 
to open a huge debate there.

If anyone, comes up with suggestions that would be great. I'll try to 
think of some myself. But again this may be too picky

thanks for the quick response,
Paul

Jim McCusker wrote:
> To be clear, we're using "qualified" as a verb, not a noun, which is why
> we can drop "had".
>
> Jim
>
> On Feb 17, 2012 8:50 AM, "Timothy Lebo" <lebot@rpi.edu
> <mailto:lebot@rpi.edu>> wrote:
>
>     1)
>     Although it doesn't shorten it up much, I think it is _much_ clearer
>     if we drop "had".
>
>     prov:hadQualifiedGeneration -> prov:qualifiedGeneration
>
>     This changes the statement from a passive to active, which will make
>     all of my writing teachers happy.
>     The Activity qualified its Generation.
>
>     This also parallels the unqualified form nicely ("generated" and
>     "qualifiedGeneration") -- a fork in the road with two routes that a
>     client can follow, depending on how much detail they want.:
>
>     :my_activity
>     a prov:Activity;
>     prov:generated :my_entity;
>     prov:qualifiedGeneration [
>     a prov:Generation;
>     prov:entity :my_entity;
>     :foo :bar;
>     ]
>     .
>
>
>     2)
>     QualifiedInvolvement -> Involvement still makes _complete_ sense,
>     since it is inherently qualifying the binary relation. Being an
>     Involvement _means_ that you're being pointed at with some
>     subproperty of prov:qualifiedInvolvement (e.g. qualifiedGeneration)
>     AND you're pointing to the (rdf:object) involvee with, say, prov:entity.
>
>     As for the predicates hanging off of the Involvement, we started
>     with just:
>
>     :my_activity prov:qualifiedGeneration [
>     a prov:Generation;
>     prov:entity :my_entity;
>     ]
>
>     but we run into a slight hiccup when we're qualifying the
>     Involvement between two Entities b/c we don't know which is the
>     rdf:subject and which is the rdf:object of the binary relation we're
>     qualifying. However, these situations start to leave core, and a
>     qualified involvement between two entities should be some Activity,
>     so we can avoid the degenerate Entity-Entity case.
>
>     -Tim
>
>
>
>     On Feb 16, 2012, at 8:53 AM, Paul Groth wrote:
>
>      > Hi All,
>      >
>      > The idea behind QualifiedInvolvement is great and it's been
>     resolved for a while so I don't want to open it up.
>      >
>      > but.... could we get a better name?
>      >
>      > The name is long, especially for the properties. So you have to
>     write:
>      >
>      > ex:activity1 prov:hadQualifiedGeneration ex:g1.
>      > ex:g1 prov:hadQualifiedEntity ex:e1.
>      > ex:g1 prov:wasGeneratedAt [owlTime:inXSDDateTime
>     2006-01-01T10:30:00-5:00].
>      >
>      > could we shorten them up somehow? Any suggestions?
>      >
>      > regards,
>      > Paul
>      >
Received on Friday, 17 February 2012 16:23:25 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 April 2012 13:06:56 GMT