W3C home > Mailing lists > Public > public-prov-wg@w3.org > February 2012

Re: prov-wg: Another name for Qualified?

From: Timothy Lebo <lebot@rpi.edu>
Date: Fri, 17 Feb 2012 08:50:51 -0500
Cc: "public-prov-wg@w3.org" <public-prov-wg@w3.org>
Message-Id: <BDEC0C06-8402-4428-8D99-A614408A006D@rpi.edu>
To: Paul Groth <p.t.groth@vu.nl>
1)
Although it doesn't shorten it up much, I think it is _much_ clearer if we drop "had".

prov:hadQualifiedGeneration  -> prov:qualifiedGeneration

This changes the statement from a passive to active, which will make all of my writing teachers happy. 
The Activity qualified its Generation.

This also parallels the unqualified form nicely ("generated" and "qualifiedGeneration") -- a fork in the road with two routes that a client can follow, depending on how much detail they want.:

:my_activity 
   a prov:Activity;
   prov:generated :my_entity;
   prov:qualifiedGeneration [
      a prov:Generation;
      prov:entity :my_entity; 
      :foo :bar;
   ]
.


2)
QualifiedInvolvement -> Involvement still makes _complete_ sense, since it is inherently qualifying the binary relation. Being an Involvement _means_ that you're being pointed at with some subproperty of prov:qualifiedInvolvement (e.g. qualifiedGeneration) AND you're pointing to the (rdf:object) involvee with, say, prov:entity.

As for the predicates hanging off of the Involvement, we started with just:

:my_activity prov:qualifiedGeneration [
   a prov:Generation;
   prov:entity :my_entity;
]

but we run into a slight hiccup when we're qualifying the Involvement between two Entities b/c we don't know which is the rdf:subject and which is the rdf:object of the binary relation we're qualifying. However, these situations start to leave core, and a qualified involvement between two entities should be some Activity, so we can avoid the degenerate Entity-Entity case.

-Tim



On Feb 16, 2012, at 8:53 AM, Paul Groth wrote:

> Hi All,
> 
> The idea behind QualifiedInvolvement is great and it's been resolved for a while so I don't want to open it up.
> 
> but.... could we get a better name?
> 
> The name is long, especially for the properties. So you have to write:
> 
> ex:activity1 prov:hadQualifiedGeneration ex:g1.
> ex:g1 prov:hadQualifiedEntity ex:e1.
> ex:g1 prov:wasGeneratedAt [owlTime:inXSDDateTime 2006-01-01T10:30:00-5:00].
> 
> could we shorten them up somehow? Any suggestions?
> 
> regards,
> Paul
> 
> 
> 
> 
> 
> 
> 
> 
> 
Received on Friday, 17 February 2012 13:51:23 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 April 2012 13:06:56 GMT