W3C home > Mailing lists > Public > public-prov-wg@w3.org > April 2012

Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

From: Daniel Garijo <dgarijo@delicias.dia.fi.upm.es>
Date: Thu, 19 Apr 2012 22:53:18 +0200
Message-ID: <CAExK0Ddh-sw-7BJbfGierikw8mmT7DBaDw+dtH7F7QUTE+D95Q@mail.gmail.com>
To: Timothy Lebo <lebot@rpi.edu>
Cc: Luc Moreau <L.Moreau@ecs.soton.ac.uk>, "public-prov-wg@w3.org" <public-prov-wg@w3.org>
Hi Tim, Luc.
>From what I understood, I thought that wasQuotedFrom was way less
restrictive.
For instance, if a blogger writes an opinion and quotes another article in
a blog post
I would expect him to assert that the post wasQuotedFrom the article:

:post prov:wasQuotedFrom :article
(Therefore the prov:hadQuoteFrom would make sense, as in your example)

Instead, if I understood correctly, we are forcing him to create an
intermediate entity just for the quote
that is used in the publication activity which generated the article. I
can't see how that is scruffy provenance
(wasn't it supposed to be a shortcut??):

:quote a prov:Entity;
          prov:wasQuotedFrom :article.

:publActivity a prov:Activity;
                  prov:used :quote;
                  prov:generated :post.

:post a prov:Entity;
        prov:wasGeneratedBy :publActivity.

Since it was a kind of derivation, I assumed that if you added additional
stuff to the entity that is repeating
some of all of the other entity it would be a quotation...
Appart from the notion of retweeting, then I don't find the shortcut very
useful, to tell you the truth. People
use to comment what they are quoting, IMO.

Thanks,
Daniel


2012/4/19 Timothy Lebo <lebot@rpi.edu>

>
> On Apr 19, 2012, at 3:31 PM, Daniel Garijo wrote:
>
> Hi Luc,
> hmmm and what about my other suggestion, "hadQuoteFrom" ?
>
>
> Daniel,
>
> I'm not in favor of changing it.
>
> I think your suggestion of hadQuoteFrom changes the meaning of the
> definition, where the quote is not THE thing taken from the original
> source, but CONTAINS something taken from the original source (and thus a
> subsequent derivation).
>
> e.g.
>
> :composite_tweet
>    a :Tweet;
>    prov:value "I have always loved the #blah. Like @Abe said, "Four score
> and seven years ago";
>    daniel:hadQuoteFrom <http://dbpedia.org/resource/Gettysburg_Address>;
>   # This is not the meaning of the current definition "the repeat of (some
> or all of) an entity.."
>    prov:wasAttributedTo twitter:timrdf,
>                                         <
> http://dbpedia.org/resource/Abraham_Lincoln>;
>    prov:qualifiedAttribution [
>        a prov:Attribution;
> prov:agent <http://dbpedia.org/resource/Abraham_Lincoln>;
>         prov:hadRole "contributor", "quoted";
>    ]
>    prov:qualifiedAttribution [
>        a prov:Attribution;
> prov:agent twitter:timrdf;
>         prov:hadRole "composer", "quoter";
>    ]
>    prov:wasDerivedFrom :actual_phrase;  ## This derivation shows the
> distinction between the meaning of what you propose and how it is currently
> defined.
> ]
>
> is NOT the same as
>
> :actual_phrase
>    a :Phrase;
>    prov:value "Four score and seven years ago";
>    prov:wasQuotedFrom <http://dbpedia.org/resource/Gettysburg_Address>;
>    prov:wasAttributedTo twitter:timrdf;
> .
>
> <http://dbpedia.org/resource/Gettysburg_Address>
>    a frbr:Work;
>    prov:wasAttributedTo <http://dbpedia.org/resource/Abraham_Lincoln>;
> .
>
> <http://en.wikipedia.org/wiki/Gettysburg_Address>
>    a foaf:Document;
>    prov:specializationOf  <http://dbpedia.org/resource/Gettysburg_Address
> >;
> .
>
>
> -Tim
>
>
>
>
>
> Thanks,
> Daniel
>
> 2012/4/19 Luc Moreau <L.Moreau@ecs.soton.ac.uk>
>
>>  Daniel,
>> We started with wasQuoteOf
>> http://www.w3.org/TR/2011/WD-prov-dm-20111018/#quotation
>> But moved away because not clear.
>>
>>  Luc
>>
>>
>> Professor Luc Moreau
>> Electronics and Computer Science
>> University of Southampton
>> Southampton SO17 1BJ
>> United Kingdom
>>
>> On 19 Apr 2012, at 17:39, "Daniel Garijo" <dgarijo@delicias.dia.fi.upm.es>
>> wrote:
>>
>>   Hi Luc,
>> the definition on DM is very clear to me.
>>
>> What makes me feel a bit unconfortable is that while I can understand
>> what is on the domain
>> and what is on the range on each of the other properties, for this one I
>> think it is a bit confusing.
>> (When I say domain and range, I refer to what is being quoted (original)
>> and what is the quote).
>>
>> I have asked 3 colleagues in my lab to tell me what did they think they
>> were the range and the domain
>> of the property with an example, (without looking at the definition of
>> the DM). One of them agreed with the DM,
>> another one guessed wrong and the last one encouraged me to change the
>> naming because "it made
>> no much sense" to him.
>>
>> I'm not sure if users that assert scruffy provenance will come to the DM
>> to read all the definitions,
>> and that is why to make sure this kind of things are very clear for
>> everyone. Thus, I don't propose
>> to change the definitions, I just suggest to rename "wasQuotedFrom" to
>> either:
>> "wasQuoteOf" or "hadQuoteFrom".
>>
>> Thanks,
>> Daniel
>>
>> 2012/4/19 Luc Moreau <L.Moreau@ecs.soton.ac.uk>
>>
>>> Hi Daniel,
>>>
>>> This is the current definition of quotation. Is there still a concern
>>> with it?
>>>
>>> Cheers,
>>> Luc
>>>
>>> 4.3.3 Quotation
>>>
>>> A quotation is the repeat of (some or all of) an entity, such as text or
>>> image, by someone other than its original author.
>>>
>>> Quotation is a particular case of derivation in which entity e2 is
>>> derived from an original entity e1 by copying, or "quoting", some or all of
>>> it. A quotation relation, written wasQuotedFrom(id,e2,e1,ag2,**ag1,attrs)
>>> in PROV-N, has:
>>>
>>> id: an optional identifier for the relation;
>>> quote: an identifier (e2) for the entity that represents the quote (the
>>> partial copy);
>>> original: an identifier (e1) for the original entity being quoted;
>>> quoterAgent: an optional identifier (ag2) for the agent who performs the
>>> quote;
>>> originalAgent: an optional identifier (ag1) for the agent to whom the
>>> original entity is attributed;
>>> attributes: an optional set (attrs) of attribute-value pairs
>>> representing additional information about this relation.
>>>
>>>
>>>
>>> On 04/19/2012 11:28 AM, Provenance Working Group Issue Tracker wrote:
>>>
>>>> PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom
>>>> [prov-dm]
>>>>
>>>> http://www.w3.org/2011/prov/**track/issues/352<http://www.w3.org/2011/prov/track/issues/352>
>>>>
>>>> Raised by: Daniel Garijo
>>>> On product: prov-dm
>>>>
>>>> Currently, the DM says:
>>>> A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,**attrs) in
>>>> PROV-ASN, contains:
>>>>     quote: an identifier e2, identifying an entity record that
>>>> represents the quote;
>>>>     quoted: an identifier e1, identifying an entity record representing
>>>> what is being quoted;
>>>> ...
>>>>
>>>> However, if we say that e2 wasQuotedFrom e1 it may look like entity e1
>>>> is the one quoting e2 (since we are saying that e2 was quoted).
>>>>
>>>> I think it would be more clear if we rename the property with e2
>>>> wasQuoteOf e1, or e2 hadQuoteFrom e1.
>>>>
>>>> Thoughts?
>>>> Thanks,
>>>> Daniel
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>  --
>>> Professor Luc Moreau
>>> Electronics and Computer Science   tel:   +44 23 8059 4487
>>> University of Southampton          fax:   +44 23 8059 2865
>>> Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
>>> United Kingdom                     http://www.ecs.soton.ac.uk/~**lavm<http://www.ecs.soton.ac.uk/%7Elavm>
>>>
>>>
>>>
>>
>
>
Received on Thursday, 19 April 2012 20:53:48 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 April 2012 13:07:03 GMT