W3C home > Mailing lists > Public > public-prov-wg@w3.org > April 2012

Re: PROV-ISSUE-347 (review-provo-luc): feedback from Luc on prov-o WD [prov-n]

From: Timothy Lebo <lebot@rpi.edu>
Date: Fri, 13 Apr 2012 20:34:02 -0400
Cc: Jun Zhao <jun.zhao@zoo.ox.ac.uk>, "public-prov-wg@w3.org" <public-prov-wg@w3.org>
Message-Id: <30A0366B-A6F8-45B1-A0F3-CC47D1906B63@rpi.edu>
To: Luc Moreau <L.Moreau@ecs.soton.ac.uk>
Luc,

On Apr 13, 2012, at 6:20 PM, Luc Moreau wrote:

> Hi Jun
> 
> For hadRole, I am fine with your answer.
> 

^^ I've marked this comment as CLOSED at http://www.w3.org/2011/prov/wiki/Prov-o_draft_review_2_April_2012


> For qualifiedXXX: whenever I read this, I always expect an unqualifiedXXX.   But obviously, it does not exist, there is only a concept XXX.


The unqualified form of qualifiedXXX is the binary predicate (yyy). (e.g. qualifiedUsage and used)
So your expected "unqualifiedXXX" == "yyy". (Also, "unqualifiedXXX" is any sub property of prov:involved, which is in the ontology.)

yyy, qualfiiedXXX, XXX, and {prov:entity, prov:activity, prov:agent) are shown in tables:

http://aquarius.tw.rpi.edu/prov-wg/prov-o#qualifed-forms-starting-point
and
http://aquarius.tw.rpi.edu/prov-wg/prov-o#qualifed-forms-expanded


Is there something in http://aquarius.tw.rpi.edu/prov-wg/prov-o#description-qualified-terms that can help make this clearer?



> 
> The other issue is that the ontology has properties such as hadActivity.
> So, when we say qualifiedXXX, do we mean "to qualify XXX" in the past tense, or "a qualified XXX".

Neither? Both? I'm not sure. This is what I think we're saying:

:activity 
   a prov:Activity;              # There is an activity
   prov:used :entity;          #  that used :entity
   prov:qualifiedUsage [   
       a prov:Usage;           #  And :activity qualified the usage of something that it used.
       prov:entity :entity;     #  :activity qualified its usage of :entity (as opposed to it's use of some other Entity that it may have used)
       :foo :bar;                     #  :activity's usage of :entity was :foo :bar
   ];
.                                          # I'm done talking about :activity.
   


> 
> I also suggested dropping "had" in some property names. 

All properties with "had" have a domain of prov:Involvement (as of tonight - I just renamed hadLocation to atLocation).
Any "hadXX" like hadActivity differs from "xx" like prov:activity in that hadActivity is NOT citing an object of an unqualified triple, while the latter is.

> Indeed, hadActivity (to have activity) vs qualifiedXXx (not to qualify XXx but a qualified XXX). This does not seem uniform.

What is not uniform about it? The "hadXXX" are properties on Involvements. The "qualifiedXXX" point to Involvements.

> 
> Dropping both qualified and had would help simplifying *labels* (it does not change the interpretation).

But this would ruin the distinctions needed for patterns of use.

prov:hadActivity differs from
prov:activity differs from 
prov:qualifiedDerivation differs from 
prov:wasDerivedFrom

and the naming conventions for all four of these are uniform for the four different places the they (and their buddies) are used.

Since this discussion resurfaces regularly, I created ISSUE-348

> 
> But that's OK, it was only a suggestion to simplify, and it was not a blocker for release. The real test is the feedback from outside the WG.


Can I close #11 at http://www.w3.org/2011/prov/wiki/Prov-o_draft_review_2_April_2012#Luc ?

Thanks,
Tim


> 
> thanks,
> 
> Professor Luc Moreau
> Electronics and Computer Science
> University of Southampton 
> Southampton SO17 1BJ
> United Kingdom
> 
> On 13 Apr 2012, at 17:23, "Jun Zhao" <jun.zhao@zoo.ox.ac.uk> wrote:
> 
>> Hi Luc,
>> 
>> I am trying to help Tim to address some of your feedback in this issue. A lot of your other feedback will be implemented during the editorial process separately.
>> 
>> 
>>> Section 4 is arid, and not systematically handled. Suggestions below.
>>> 
>>> * Are the comments within the OWL file adequate to familiarize with the structure? If not, what kinds of comments would help?
>> 
>> This is a todo for us now. We will add more annotations to the OWL file rather than linking to the DM.
>> 
>>> 
>>> 11. Section 3.3:
>>> choice of name: you have prov:qualifiedUsage, etc
>>> why not simply prov:usage?
>> 
>> Because these properties are to be used for expressing "qualified relationships". I think with a qualitied- "prefix", it's easier for people to realize that this is a qualified property. Without it, prov:usage becomes vague and less straightforward, and people have to go and read documentation to understand what this is about.
>> 
>> What do you think?
>> 
>>> 
>>> 23. Role is defined in the context of usage, generation, association,
>>> start and end, but hadRole has all involvments in its domain, including derivation and collection-derivations.
>> 
>> 
>> I think this has is also related to thread [1].
>> 
>> Such similar feedback have come several times. And I would like us to consider two additional things:
>> 
>> 1) The prov-o is an OWL-RL ontology that implements DM. Given the set of semantics that can be expressed using OWL-RL, we couldn't have a one-to-one implementation of DM, just like a prov-xml schema cannot either. It's a compromised made for implementation.
>> 
>> 2) Even if we do have a perfect prov-o implementation of DM, there is still nothing we can do to prevent people from using it wrongly or saying stupid things. The abuse of ontologies/vocabularies on the Semantic Web is nearly universal.
>> 
>> 
>> 3) A possibility of saying something is different from being able to automatically infer that something. Our use of OWL-RL does provide a possibility for users to associate a derivation with a role, but the RL semantics would *not* infer that if something is a derivation, then it must have some sort of role. This is the best I can do for explanation and I hope I got it right:). A sensible user of prov-o, if read the spec properly, then would/should not have abused "hadRole".
>> 
>> See also Tim's original example in [2].
>> 
>> (prov:hadActivity rdfs:domain prov:Involvement .
>> :s prov:hadActivity :a
>> --------
>> :s a prov:Involvement
>> 
>> 
>> this is different than saying:
>> 
>> :q a prov:Quotation
>> -------
>> :q prov:hadActivity :activity)
>> 
>> 
>> The current implementation of prov-o is a compromise that we made so that we can use OWL-RL. A justification of OWL-RL is a separate issue. The prov-o team were strongly advised to use OWL-RL and that's what we did. I don't think you are *not sympathetic* of their situation and the problems that they had to deal with or had dealt with. :)
>> 
>> I suggest what we can do with this problem is in section 4, when we define the properties like "hadRole" or "hadActivity", we make it clear what/how we exactly expect people to use these properties.
>> 
>> Would that sound like a good compromise to you? If you do, then we will act upon that.
>> 
>> [1] http://lists.w3.org/Archives/Public/public-prov-wg/2012Apr/0145.html
>> [2] http://lists.w3.org/Archives/Public/public-prov-wg/2012Apr/0168.html
>> 
>> cheers,
>> 
>> -- Jun
>> 
>> 
>> 
>> 
>> 
> 
> 
Received on Saturday, 14 April 2012 00:34:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 April 2012 13:07:03 GMT