W3C home > Mailing lists > Public > public-owl-wg@w3.org > March 2008

comment on primer: RDF/XML encoding of property lists....

From: Ivan Herman <ivan@w3.org>
Date: Mon, 31 Mar 2008 15:35:21 +0200
Message-ID: <47F0E899.1020601@w3.org>
To: Bijan Parsia <bparsia@cs.man.ac.uk>, "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>, public-owl-wg@w3.org
I know that this is still a matter of discussion, ie, it is intentional. 
But if not...

In the examples the RDF/XML syntax for property list is:

<rdf:Description>
    <rdf:type rdf:resource="&rdf;List"/>
    <rdf:first rdf:resource="#hasSpouse"/>
    <rdf:rest rdf:parseType="Collection">
       <rdf:Description rdf:about="#hasSon"/>
    </rdf:rest>
    <rdfs:subPropertyOf rdf:resource="#hasSon"/>
</rdf:Description>

ie, in turtle (it is sooo much more readable:-):

( :hasSpouse :hasSon ) rdfs:subPropertyOf :hasSon .

However, my reading of the RDF Mapping is that the correct mapping 
should be:

[] rdfs:subPropertyOf :hasSon;
    owl11:propertyChain ( :hasSpouse :hasSon ).

at least to reflect the correct state of the art... I know that the 
exact mapping is still under discussion, but maybe an editorial note in 
the document saying that this is still an issue and later releases will 
  align the document on that point would be a good idea...

Ivan

-- 

Ivan Herman, W3C Semantic Web Activity Lead
Home: http://www.w3.org/People/Ivan/
PGP Key: http://www.ivan-herman.net/pgpkey.html
FOAF: http://www.ivan-herman.net/foaf.rdf


Received on Monday, 31 March 2008 13:35:53 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 31 March 2008 13:35:55 GMT